Ask Your Question
0

robot-brand the PR2 from basestation

asked 2014-02-18 05:21:37 -0600

Erwan R. gravatar image

Hello,

I'd like to have some clarification to be sure to understand the Configuring Basestation tutorial. In my understanding :

1.4.3. Contact Your Sysadmin :

This step is necessary for the Sysadmin to allow the BaseStation to connect on the Building Network. It also allows (the DNS entries) any user on the Building network to access the BaseStation and the PR2 through the BaseStation from their name (initially basestation, c1 and c2). And the DHCP access for c1 is used to connect PR2 with WAN port on the Building Network. In our situation, we are connected on the Building Network through a router that "masks" BaseStation and PR2 IPs on the rest of the network. Thus, we didn't require the corresponding DNS entries, as we don't want the robot to be accessible from any computer of the lab, but only the BaseStation or a computer in the Primary internal network (i.e. a person physically next to the robot).

1.5. Configure the Basestation Network

What does yourdomain.com correspond to ? Is it the lab subnet in university ? Could you provide an example ?

1.5.3. Interfaces File

As we are masked behind the router, is <base_ip> the IP given from the router ? Shouldn't "gateway" be the IP of the router ?

1.5.4. Resolv.conf File

This file is flagged :

 "# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)"
 "# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN"

It seems to appear since Ubuntu 12.04. As far as I understand, using a static IP could change that behaviour (and keep a modified resolv.conf), is that true ?

We had a look at robot-brand script, I understand that, from the correct setup of the BaseStation, it configure the PR2 network with the correct informations. Am I right ?

1.6. Verify Working Robot

Is this step doable from any computer on the Primary Internal Network of the robot (from WAP or SP) ? Any computer from the Building network if the BaseStation and PR2 weren't behind a router ?

Thanks for reading,

Erwan

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-02-18 07:19:38 -0600

ahendrix gravatar image

The PR2 automatic network switching and its interactions with ROS rely very heavily on being able to resolve hostnames properly.

If you're behind a lab router/firewall, you should configure your lab router to serve DNS for your lab. Some newer routers support this automatically, as does the ddwrt firmware. When you do this, you'll have the option to set the domain suffix for your lab. You can choose anything you like, but it's a good idea to try to pick something that is unused, because it will override any public DNS records. yourdomain.com corresponds to the DNS subdomain you choose for your lab.

If you can't get a local DNS server running on your router, you can manually add the hostnames and IPs for your PR2 to /etc/hosts on all of the computers on your lab network, but this is generally a maintenance nightmare.

Regarding /etc/resolve.conf, the DNS configuration moved to /etc/network/interfaces during the switch to Precise, and it looks like that tutorial didn't get updated. See Chapter 14.

Once you have the networking set up properly, you should be able to do step 1.6 from any computer on your lab network.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-02-18 05:21:37 -0600

Seen: 313 times

Last updated: Feb 18 '14