Ask Your Question
0

Does anyone have a ur5 working with moveit and hydro?

asked 2014-02-12 01:20:39 -0500

Rob Farrell gravatar image

I've tested my hydro installation successfully with pr2 and the pr2_moveit_config and the demo.lauch file and I've updated my ur5 move_group.launch file with the requisite move_group/MoveGroupGetPlanningSceneService and indicated at groups.google.com/forum/#!topic/moveit-users/mUQqqFsGu9U however when I roslaunch the ur5 demo.lauch or the moveit_planning _execution.launch file rviz comes up for an instant and the I get an exit code -11. From what I've read this is a seg fault and I'll need to run gdb to further debug however I've tested this on two fresh installation of ubuntu 12.04 x64 and have the same result however the pr2 demo.launch seems to function normally. Can someone offer some guidance here?

edit retag flag offensive close merge delete

Comments

Is your MoveIt config the one from the ROS-Industrial universal_robot repository? Or is it a custom made one?

gvdhoorn gravatar image gvdhoorn  ( 2014-02-12 19:50:39 -0500 )edit

Currently I'm only trying to get the default ROS-industrial universal_robots hydro-dev repository to work. I have also tried my own universal_robots and Marco's from below. All give the same result.

Rob Farrell gravatar image Rob Farrell  ( 2014-02-13 01:58:47 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2014-02-16 15:35:05 -0500

Rob Farrell gravatar image

It turns out the stock ur5_moveit_config ur5.srdf has the base_link as part of the manipulator planning group. Apparently this worked in groovy but not in hydro. The link can be removed from the manipulator planning group by using the setup_assistant planning groups tab, it can also be seen in the ur5_moveit_config ur5.srdf.

edit flag offensive delete link more

Comments

@Rob Farrell: could you open a ticket about this against the universal_robot repository? This might affect other packages as well. Thanks. The weird thing is that all ROS-I packages include the base_link in the manipulator group, and it works fine as far as I know.

gvdhoorn gravatar image gvdhoorn  ( 2014-02-16 19:57:42 -0500 )edit

It would seem the UR5 MoveIt cfg uses a set of links, instead of a single chain, which is different from other ROS-I cfgs. I'm not sure why it is setup like that, there might be a valid reason.

gvdhoorn gravatar image gvdhoorn  ( 2014-02-16 20:00:23 -0500 )edit
1

Just to follow up on this: https://github.com/ros-industrial/universal_robot/pull/45 should fix the described issue.

gvdhoorn gravatar image gvdhoorn  ( 2014-03-31 21:04:25 -0500 )edit
0

answered 2014-02-12 05:17:39 -0500

jeff-o gravatar image

I am having similar issues as Rob; rviz launches and crashes just seconds later. I am able to connect to the arm, get position feedback and command it just fine.

I'd also appreciate any tips on how to get the UR5 MoveIt implementation to launch.

edit flag offensive delete link more
0

answered 2014-02-12 08:59:08 -0500

marcoesposito1988 gravatar image

It's a long while since I got it working in my repo, but it could be due to the SRDF not in sync with the URDF. This can be corrected by running again the moveit setup assistant.

But I'm using the UR5 right now with a development of my repo (I attached an end effector you aren't interested in for sure), so the base code for it should work:

https://github.com/marcoesposito1988/...

Please let me know if you encounter more problems.

Cheers, Marco

edit flag offensive delete link more

Comments

Thanks Marco. Unfortunately I tried both running the setup assistant again and I tried using your fork and unfortunately the result is the same. It all looks good in the setup assistant however when I try to launch the demo rviz comes up and then closes quickly. Still stumped. I must be missing something.

Rob Farrell gravatar image Rob Farrell  ( 2014-02-12 16:00:31 -0500 )edit

Ok, then you may have something wrong on your setup. You should launch Rviz with the debug argument, so that it is executed in GDB and we can see from the backtrace where the problem is Cheers Marco

marcoesposito1988 gravatar image marcoesposito1988  ( 2014-02-12 19:39:08 -0500 )edit

I turned on the debug and this is what I get at the end: Program received signal SIGSEGV, Segmentation fault. 0x00007fff987983b3 in dynamics_solver::DynamicsSolver::DynamicsSolver(boost::shared_ptr<moveit::core::robotmodel const=""> const&, std::string const&, geometry_msgs::Vector3_<std::allocator<void> > const&) () from /opt/ros/hydro/lib/libmoveit_dynamics_solver.so

Rob Farrell gravatar image Rob Farrell  ( 2014-02-13 02:07:49 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-02-12 01:20:39 -0500

Seen: 794 times

Last updated: Feb 16 '14