Ask Your Question
0

Rviz doesn't recieve kinect streams from turtlebot

asked 2012-01-10 08:57:18 -0500

Robert Buzink gravatar image

updated 2016-10-24 08:59:22 -0500

ngrennan gravatar image

I'm trying to do SLAM-mapping using a Turtlebot. The kinect works, but RVIZ doesn't recieve any data from it. I have the following errors:

error 1 (in dashboard):

Node: /rviz_1326231834235022764 Time: 1326233463.821563932 Severity: Warn Location: /opt/ros/electric/stacks/geometry/tf/include/tf/message_filter.h:MessageFilter<m>::checkFailures:481 Published Topics: /rosout, /initialpose, /move_base_simple/goal

MessageFilter [target=/map ]: Dropped 100.00% of messages so far. Please turn the [ros.rviz.message_notifier] rosconsole logger to DEBUG for more information.

error 2 (in rviz): Camerainfo

No camerainfo recieved on camera/depth/camera_info]. Topic may not exist.

Error 3 Sometimes I get this error in dashboard:

Node: /openni_manager Time: 1326234101.630842089 Severity: Warn Location: /tmp/buildd/ros-electric-openni-kinect-0.3.2/debian/ros-electric-openni-kinect/opt/ros/electric/stacks/openni_kinect/openni_camera/src/nodelets/openni_nodelet.cpp:OpenNINodelet::subscriberChangedEvent:352 Published Topics: /rosout, /camera/rgb/image_color/compressed, /camera/rgb/image_color/compressed/parameter_descriptions, /camera/rgb/image_color/compressed/parameter_updates, /camera/rgb/image_color, /camera/rgb/image_color/theora, /camera/rgb/image_color/theora/parameter_descriptions, /camera/rgb/image_color/theora/parameter_updates, /camera/rgb/image_raw/compressed, /camera/rgb/image_raw/compressed/parameter_descriptions, /camera/rgb/image_raw/compressed/parameter_updates, /camera/rgb/image_raw, /camera/rgb/image_raw/theora, /camera/rgb/image_raw/theora/parameter_descriptions, /camera/rgb/image_raw/theora/parameter_updates, /camera/rgb/image_mono/compressed, /camera/rgb/image_mono/compressed/parameter_descriptions, /camera/rgb/image_mono/compressed/parameter_updates, /camera/rgb/image_mono, /camera/rgb/image_mono/theora, /camera/rgb/image_mono/theora/parameter_descriptions, /camera/rgb/image_mono/theora/parameter_updates, /camera/depth/image/compressed, /camera/depth/image/compressed/parameter_descriptions, /camera/depth/image/compressed/parameter_updates, /camera/depth/image, /camera/depth/image/theora, /camera/depth/image/theora/parameter_descriptions, /camera/depth/image/theora/parameter_updates, /camera/depth/image_raw/compressed, /camera/depth/image_raw/compressed/parameter_descriptions, /camera/depth/image_raw/compressed/parameter_updates, /camera/depth/image_raw, /camera/depth/image_raw/theora, /camera/depth/image_raw/theora/parameter_descriptions, /camera/depth/image_raw/theora/parameter_updates, /camera/depth/disparity, /camera/rgb/camera_info, /camera/depth/camera_info, /camera/depth/points, /camera/rgb/points, /openni_camera/parameter_descriptions, /openni_camera/parameter_updates, /openni_manager/bond, /narrow_scan, /kinect_laser_narrow/parameter_descriptions, /kinect_laser_narrow/parameter_updates, /cloud_throttled, /scan, /kinect_laser/parameter_descriptions, /kinect_laser/parameter_updates

Camera Info for rgb stream has subscribers, but stream has stopped.

Any ideas?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-01-11 10:43:26 -0500

Robert Buzink gravatar image

Apparently I messed around with rviz settings too much. After I set fixed_frame to /base_link and target Frame to <fixed frame=""> in .Global Options, everything worked as expected. You can set the options in the rviz window or in .rviz/config and .rviz/display_config.

edit flag offensive delete link more
2

answered 2012-01-10 11:54:09 -0500

ahendrix gravatar image

This looks like a message version mismatch between the computer running rviz and the turtlebot. Are you running the same version of ROS on both?

edit flag offensive delete link more

Comments

Thanks for the suggestion! But I am running electric on ubuntu 11.10 on both master and slave.
Robert Buzink gravatar image Robert Buzink  ( 2012-01-11 01:50:43 -0500 )edit
This could also be a problem with your choice of coordinate frames in rviz. If your fixed or target frame isn't valid, rviz will fail to find a transform from the the camera frame to your target frame, so it displays nothing. Try choosing a different frames.
ahendrix gravatar image ahendrix  ( 2012-01-11 08:40:54 -0500 )edit
Thanks, that worked! I'll put it an answer below. Thanks for your great help!
Robert Buzink gravatar image Robert Buzink  ( 2012-01-11 10:34:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-01-10 08:57:18 -0500

Seen: 537 times

Last updated: Jan 11 '12