foreign_relay problem [closed]

asked 2011-12-20 23:23:50 -0600

Per Lenander gravatar image

updated 2011-12-21 20:43:35 -0600

Hi!

I'm trying to get a multimaster setup working. I have several computers/robots with identical hardware trying to talk to each other using foreign_relay from the multimaster_experimental stack.

I run something along the lines of:

rosrun foreign_relay foreign_relay adv http://OtherRobot:11311 test test

Then I start some topic on the local master:

rostopic pub -r 10 test std_msgs/String "hello"

Echoing the topic shows hello as expected.

I can also see a message from the foreign_relay that the topic has been registered on the foreign master with the correct message type. Checking the foreign master, the topic has indeed been started there, but there is no data being sent on it (no "hello" reaching the foreign master). I tried the above simulation using foreign_relay sub instead but with the same result.

I read this question: http://answers.ros.org/question/1040/help-troubleshooting-foreign-relay

This guy seems to have had the same problem as me, but his solution did not work for me. The two computers are already on the same subnet (on the same linksys router, with both computers having static IPs).

UPDATE: I tried the same setup, same commands on two different computers, connected to an entirely different network and I got the exact same result.

I also tried the solution suggested in http://answers.ros.org/question/1554/successful-use-of-wifi_comm but setting the ROS_IP and ROS_MASTER_URI in .bashrc and sourcing it did not help.

How come that master A can clearly connect to master B and register a topic there, but that sending data on the same topic doesn't work?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2013-09-06 13:37:31

Comments

Hi! I have exactly the same problem as you have. Did you ever solve this problem? Any help is appreciated.

alirezadh1234 gravatar imagealirezadh1234 ( 2013-07-21 07:38:38 -0600 )edit

try 'rosrun foreign_relay foreign_relay adv http://OtherRobot:11311 /test /test' . placing a '/' worked for me

jithinreju@gmail.com gravatar imagejithinreju@gmail.com ( 2019-01-15 09:19:50 -0600 )edit