Ask Your Question
1

Issues launching nao_sim

asked 2014-01-29 08:35:30 -0600

Quinton Anderson gravatar image

updated 2014-02-17 01:55:36 -0600

AHornung gravatar image

Hi Guys,

I am currently on a mission to recreate 3d navigation functionality described in the paper "Real-Time Navigation in 3D Environments Based on Depth Camera Data" by Armin Hornung et. el.

I have gone through the process of installing and validating the ROS install (Hydro), and am now trying to just get the following command to work:

roslaunch nao_bringup nao_sim.launch

When I launch the command I get the following error:

> NODES   /
>     base_footprint (nao_description/base_footprint)
>     nao_behaviors (nao_driver/nao_behaviors.py)
>     nao_controller (nao_driver/nao_controller.py)
>     nao_leds (nao_driver/nao_leds.py)
>     nao_sensors (nao_driver/nao_sensors.py)
>     nao_speech (nao_driver/nao_speech.py)
>     nao_tactile (nao_driver/nao_tactile.py)
>     nao_walker (nao_driver/nao_walker.py)
>     pose_manager (nao_pose/pose_manager.py)
>     robot_state_publisher (robot_state_publisher/state_publisher)
> 
> ROS_MASTER_URI=XXX
> 
> core service [/rosout] found
> process[robot_state_publisher-1]:
> started with pid [6401]
> process[base_footprint-2]: started
> with pid [6402]
> process[nao_sensors-3]: started with
> pid [6443] process[nao_walker-4]:
> started with pid [6444] No handlers
> could be found for logger "rosout"
> process[nao_controller-5]: started
> with pid [6449] No handlers could be
> found for logger "rosout"
> process[nao_behaviors-6]: started with
> pid [6450]
> ================================================================================REQUIRED process [nao_sensors-3] has died!
> process has died [pid 6443, exit code
> 1, cmd
> /home/vagrant/workspce/src/nao_robot/nao_driver/nodes/nao_sensors.py --pip=127.0.0.1 --pport=9559 __name:=nao_sensors __log:=/home/vagrant/.ros/log/cab0b7cc-88c4-11e3-9375-080027880ca6/nao_sensors-3.log]. log file:
> /home/vagrant/.ros/log/cab0b7cc-88c4-11e3-9375-080027880ca6/nao_sensors-3*.log
> Initiating shutdown!
> ================================================================================ cannot add process [nao_leds-7] after
> process monitor has been shut down
> [nao_behaviors-6] killing on exit
> [nao_controller-5] killing on exit 
> [nao_walker-4] killing on exit
> Traceback (most recent call last):  
> File
> "/home/vagrant/workspce/src/nao_robot/nao_driver/nodes/nao_controller.py",
> line 39, in <module>
>     import nao_msgs.msg [nao_sensors-3] killing on exit   File
> "/home/vagrant/workspce/devel/lib/python2.7/dist-packages/nao_msgs/msg/__init__.py",
> line 39, in <module> Traceback (most
> recent call last):   File
> "/home/vagrant/workspce/src/nao_robot/nao_driver/nodes/nao_behaviors.py",
> line 36, in <module>
>     import rospy   File "/opt/ros/hydro/lib/python2.7/dist-packages/rospy/__init__.py",
> line 49, in <module>
>     from ._JointAngleTrajectory import *   File "/home/vagrant/workspce/devel/lib/python2.7/dist-packages/nao_msgs/msg/_JointAngleTrajectory.py",
> line 1, in <module>
>     """autogenerated by genpy from nao_msgs/JointAngleTrajectory.msg. Do
> not edit.""" KeyboardInterrupt
>     from .client import spin, myargv, init_node, \   File
> "/opt/ros/hydro/lib/python2.7/dist-packages/rospy/client.py",
> line 48, in <module> 
> [base_footprint-2] killing on exit
>     import rosgraph   File "/opt/ros/hydro/lib/python2.7/dist-packages/rosgraph/__init__.py",
> line 36, in <module>
>     from . masterapi import Master, MasterFailure, MasterError,
> MasterException   File
> "/opt/ros/hydro/lib/python2.7/dist-packages/rosgraph/masterapi.py",
> line 45, in <module>
>     from . names import make_caller_id   File
> "/opt/ros/hydro/lib/python2.7/dist-packages/rosgraph/names.py",
> line 39, in <module>
>     import os KeyboardInterrupt [robot_state_publisher-1] killing on
> exit

I have validated that the required packages are installed using rosdeps and roscd.

I am on ubuntu precise64, ROS hydro and pynaoqi-python-2.7-naoqi-1.14-linux64.

Any help would be appreciated!

edit retag flag offensive close merge delete

Comments

What happens if you just start a single node, e.g. "rosrun nao_driver nao_sensors.py"? (start a roscore in a separate terminal before, as well as NaoQI)

AHornung gravatar imageAHornung ( 2014-02-17 21:51:31 -0600 )edit

I have only tried for 30 minutes, but at this stage that command simply exits without any real output, besides: No handlers could be found for logger "rosout" I have checked the logs, they are also empty. I will continue some more tomorrow.

Quinton Anderson gravatar imageQuinton Anderson ( 2014-02-18 22:35:08 -0600 )edit

have you sourced your workspace? Like the command below source /devel/setup.bash

dnth gravatar imagednth ( 2014-02-20 17:49:43 -0600 )edit

yes, I have sourced ./devel/setup.bash

Quinton Anderson gravatar imageQuinton Anderson ( 2014-02-20 19:48:08 -0600 )edit

Hi! I have the same poblems, No handlers could be found for logger rosout. My configuration system is similar (ubuntu 12.04 64, ROS hydro and pynaoqi 1.14.5) for the Installation of ROS for NAO I followed the Armin's tutorials "ROS on a remote PC" but I installed just the precompiled binaries. should I uninstall them and install the github ones? including the extras_nao? Quinton Anderson, did you solve the problem? thank you!

PabloM gravatar imagePabloM ( 2014-03-13 00:24:38 -0600 )edit

Hi, I didn't get it working, but I haven't tried very hard yet. I have been distracted at work. I will get back to focussing on it shortly.

Quinton Anderson gravatar imageQuinton Anderson ( 2014-03-13 00:47:20 -0600 )edit

Quinton, our problem is the linking with the pynaoqi (export PYTHONPATH="$PYTHONPATH:$HOME/path/to/pynaoqi/") in my case i have an error in the path to pynaoqi. now I have other problem when i launch the NAOnodes (ERROR: cannot launch node of type [nao_driver/nao_sensors_cpp]: can't locate node [nao_sensors_cpp] in package [nao_driver]) .

PabloM gravatar imagePabloM ( 2014-03-21 03:55:08 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-03-21 04:16:08 -0600

AHornung gravatar image

@PabloM That is a different problem, you try to launch the C++ nodes. They require that you compile them for the robot (with the C++ SDK). You should try launching the Python nodes instead.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-01-29 08:35:30 -0600

Seen: 972 times

Last updated: Feb 17 '14