Ask Your Question
0

installing stack ccny_vision

asked 2011-12-06 01:22:27 -0600

Maurizio88 gravatar image

hi all, i can't install the stack ccny_vision. i'm following the instruction, but i have some errors when i run

rosmake ccny_vision --rosdep-install.

i solved the first one with:

Run the following commands to remove the offending line:

roscd ccny_vision sed -i '/ubuntu: libglut3-dev/d' rosdep.yamllibglut3-dev/d' rosdep.yaml

libglut3-dev/d' rosdep.yaml

but when i build the ccny_vision stack:

rosmake/rosmake_output-20111206-162013

rosmake/rosmake_output-20111206-162013> mkdir -p build mkdir: impossibile

creare la directory "build": Permesso negato make: [build/artoolkit/unpacked] Errore 1 (ignorato) if [ ! -f ARToolKit-SVN-r311.tar.gz.md5sum ]; then echo "Error: Couldn't find md5sum file ARToolKit-SVN-r311.tar.gz.md5sum" && false; fi rospack find rosbuild/bin/download_checkmd5.py https://code.ros.org/svn/release/download/thirdparty/ARToolKit-SVN-r311.tar.gz build/ARToolKit-SVN-r311.tar.gz awk {'print $1'} ARToolKit-SVN-r311.tar.gz.md5sum
Traceback (most recent call last): File "/opt/ros/electric/ros/core/rosbuild/bin/download_checkmd5.py", line 56, in <module> sys.exit(main()) File "/opt/ros/electric/ros/core/rosbuild/bin/download_checkmd5.py", line 22, in main os.makedirs(d) File "/usr/lib/python2.7/os.py", line 157, in makedirs mkdir(name, mode) OSError: [Errno 13] Permission denied: 'build' -------------------------------------------------------------------------------} [ rosmake ] Output from build of package artoolkit written to: [ rosmake ]
/home/mauro/.ros/rosmake/rosmake_output-20111206-162013/artoolkit/build_output.log [rosmake-1] Finished <<< artoolkit [FAIL] [ 0.09 seconds ]
[rosmake-0] Starting >>> nav_msgs [ make ]
[rosmake-0] Finished <<< nav_msgs ROS_NOBUILD in package nav_msgs
[rosmake-0] Starting >>> diagnostic_msgs [ make ]
[rosmake-0] Finished <<< diagnostic_msgs ROS_NOBUILD in package diagnostic_msgs
[rosmake-0] Starting >>> test_common_msgs [ make ]
[ rosmake ] Halting due to failure in package artoolkit. [ rosmake ] Waiting for other threads to complete. [rosmake-0] Finished <<< test_common_msgs ROS_NOBUILD in package test_common_msgs
[ rosmake ] Results:
[ rosmake ] Built 63 packages with 1 failures.
[ rosmake ] Summary output to directory
[ rosmake ] /home/mauro/.ros/rosmake/rosmake_output-20111206-162013rosmake/rosmake_output-20111206-162013 rosmake/rosmake_output-20111206-162013

edit retag flag offensive close merge delete

Comments

where is the folder ccny_vision downloaded to... path?
karthik gravatar imagekarthik ( 2011-12-06 01:52:16 -0600 )edit

What is the solution to this problem, I am having the same error..

ayush_dewan gravatar imageayush_dewan ( 2012-05-13 00:38:39 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2011-12-06 02:08:09 -0600

karthik gravatar image

You are trying to create a directory in the /opt/ros/electric/ros/core path.

You will not have permission to create something in that place. If you still want to do it. You can change the permission of the ccny_vision folder with write access. I suggest you to have a ros_workspace created as given in the below page

http://www.ros.org/wiki/ROS/Tutorials/InstallingandConfiguringROSEnvironment

and use the same path for the future packages that you download and install. In this particular case, just have this workspace created and setup the environment. Paste your ccny_vision folder there and try to execute your commands.

Hope this helps, Karthik

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-12-06 01:22:27 -0600

Seen: 761 times

Last updated: Dec 06 '11