Ask Your Question
0

Why does ROS installation fails on 64bit Linux

asked 2014-12-24 22:42:11 -0500

Amjadov gravatar image

Hi,

So my goal is to install ROS and Matlab on a Ubuntu 14.04 laptop, simple right? I started with a fresh installation of Ubuntu 14.04 and went ahead to install ROS, I followed the installation instructions in the ROS wiki but I always get the "ROS-indigo-desktop-full depends on ROS-indigo-symantics..." and other dependencies.

I googled this issue and tried every possible scenario or suggestion but there wasn't much help, though I figured it is related to my Ubuntu being 64bit, so I decided to erase everything and install ubuntu 14.04 32bit, after I did that ROS amazingly installed without a single problem and ran smoothly.

BUT then I discovered that Matlab can only install on a 64bit linux! I tried to find a workaround but with no luck, so back to square one.

I erased everything and installed Ubuntu 14.04 64bit, and back to the dependency hell!!! ROS does not install and no solution for that on the internet.

It's been 10 days now and I still cannot install ROS and Matlab together, I would appreciate any help please.

edit retag flag offensive close merge delete

Comments

I'm pretty sure you did the installation right, but in my 64 bit run both: ROS and Matlab. I haven't done nothing special, just followed the instruction on ROS website. Here my Xubuntu 14.04

Linux YE-166 3.13.0-43-generic #72-Ubuntu SMP Mon Dec 8 19:35:06 UTC 2014 x86_64 x86_64 x86_64 GNU/Linu
Andromeda gravatar image Andromeda  ( 2014-12-25 06:35:22 -0500 )edit

It installed on the same laptop on Ubuntu 32bit smoothly without any problems, but on 64 bit it doesn't.

Btw I also tried to install it on a VM running 64bit Lubuntu but I got the same problem.

Amjadov gravatar image Amjadov  ( 2014-12-25 08:06:06 -0500 )edit

Did you install a desktop version of your Ubuntu distro? I never had a problem to install 64bit

Andromeda gravatar image Andromeda  ( 2014-12-26 02:31:59 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-12-25 08:04:00 -0500

Amjadov gravatar image

updated 2014-12-27 00:03:07 -0500

Thanks guys for the help.

I finally solved it! it turned out that after I installed Ubuntu 14.04 64bit, somehow I upgraded my version to 14.10 Utopic, and this version of ubuntu is not compatible with ROS.

I re-installed Trusty and everything went fine.

edit flag offensive delete link more

Comments

check your answer as accepted

Andromeda gravatar image Andromeda  ( 2014-12-28 10:16:58 -0500 )edit
0

answered 2014-12-26 13:37:36 -0500

neoDEH gravatar image

i think your answer is in section 1.4 http://wiki.ros.org/indigo/Installati...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-12-24 22:42:11 -0500

Seen: 850 times

Last updated: Dec 27 '14