Ask Your Question
0

librobot_control.so bad plugin info hash

asked 2011-12-05 06:06:57 -0500

chriscannon gravatar image

Hello,

I installed the openrave_robot_control plugin under ROS Diamondback and I was able to successfully run "rosmake" on the source. Then I loaded the plugin into my OPENRAVE_PLUGINS environment variable: export OPENRAVE_PLUGINS=$OPENRAVE_PLUGINS:rospack find openrave/share/openrave/plugins:rospack find openrave_robot_control/lib

The issue comes when I run "openrave --listplugins" and I get the following error: [plugindatabase.h:832] /opt/ros/diamondback/stacks/openrave_planning/openrave_robot_control/lib/librobot_control.so failed to load: openrave (InvalidPlugin): [void OpenRAVEGetPluginAttributes(OpenRAVE::PLUGININFO, int, const char):87] bad plugin info hash

Anyone else experience this?

Thanks, Chris

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2011-12-06 04:08:47 -0500

chriscannon gravatar image

Turns out the issue was because I had installed OpenRAVE separately from the ROS stack of OpenRAVE. This occurs because during compilation it looks under /usr/bin/openrave which is not linked to the ROS stack OpenRAVE. After uninstalling the separate version of OpenRAVE and re-running rosmake in the openrave_robot_control directory everything worked perfectly.

edit flag offensive delete link more
0

answered 2011-12-05 16:15:36 -0500

hi chris,

most likely something got cached, try:

roscd openrave_robot_control
make clean
make
edit flag offensive delete link more

Comments

I tried your suggestion and it still produces the same error.
chriscannon gravatar image chriscannon  ( 2011-12-06 01:15:58 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-12-05 06:06:57 -0500

Seen: 169 times

Last updated: Dec 06 '11