rviz segfault after multiple machine network setup [closed]

asked 2011-11-28 10:24:04 -0600

Khiya gravatar image

updated 2014-01-28 17:10:53 -0600

ngrennan gravatar image

Hello all,

I'm trying to set up a reliable way to run RVIZ on a remote computer (acting as the brains for a homebrew robot) either by using VNC from a laptop running Windows or by using some sort of multiple machine network setup from a different laptop running Linux Mint with ROS. Specs:

Remote robot brain computer: Name: xbot, an ASUS Eee Box PC EB1012P OS: Ubuntu 11.04 with ROS electric IP address: my.robot.i.p

Windows laptop: Name: mypc, a Dell Latitude E6400 OS: Windows Vista, running TightVNC or SSH IP address: my.pc.i.p

LinuxMint laptop: Name: myROSpc, an ASUS EeePC 1000HE OS: Linux Mint 11, optionally running TightVNC IP address: my.ROSpc.i.p

Basically, I keep running into an RVIZ segmentation fault whenever I try to start rviz remotely, ie, rosrun rviz rviz. Using TightVNC from mypc to xbot clearly doesn't work - I gather that's because RVIZ absolutely needs to be started on its local computer.

I would like to try implementing the distributed ROS setup described in http://www.ros.org/wiki/ROS/NetworkSetup. I've followed that procedure using, for example, myROSpc as marvin and xbot as hal, and I've achieved successful communication as far as pinging goes. But even so, when my ROS_MASTER_URI is set to my.robot.i.p and I type rosrun rviz rviz from myROSpc, behold, segmentation fault. Specifically, the fault information continues to be exactly:

$ rosrun rviz rviz
[INFO][*timestamp*]: rviz revision number 1.6.5
[INFO][*timestamp*]: ogre_tools revision number 1.6.2
[INFO][*timestamp*]: compiled against OGRE version 1.7.3 (Cthugha)
Segmentation fault

Am I just out of luck with remote RVIZ operation? Could it be a compilation error? Any help from other threads that I've overlooked?

Incidentally, this thread (http://answers.ros.org/question/711/rviz-segfaults-unless-a-monitor-is-connected-any) has a lot of pertinent info but none of the fixes has worked for me. I even tried VirtualGL but either I configured my server improperly or there's a deeper issue that keeps it from working (xbot was my server in this case - SSHing into xbot from myPC and running rviz through vglrun still produced a segfault) .

I'd appreciate any clarifications and help!

-Khiya

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2013-09-06 13:28:07

Comments

Hello, what's the role of the windows PC in this 3 computer configuration?

SL Remy gravatar imageSL Remy ( 2012-06-18 09:29:10 -0600 )edit