Ask Your Question
1

"Lost sync" with Arbotix and rosserial [closed]

asked 2011-11-25 01:54:44 -0500

Pi Robot gravatar image

updated 2011-11-25 02:00:35 -0500

In another post I reported a "Lost sync" problem when using rosserial with an Arudino Uno over an XBee connection. That problem was resolved by always using a baud rate of 57600 for the radios and the rosserial connection.

Now I have the same problem with an Arbotix board (version 1). This time, I can't resolve the problem with any choice of baud rate. Here are some tests I have run:

  • rosserial works fine over a hardwire USB connection to the ArbotiX at 57600
  • Serial.println() works fine over XBee at 57600 baud from the ArbotiX back to the PC
  • The ArbotiX ROS interface (arbotix_python) works fine over a hardwire USB connection at 57600
  • The arbotix_python package does not work over XBee (e.g. rostopic echo /joint_states always returns 0.0 for servo positions)

So there seems to be some problem with getting data from the PC to the ArbotiX over XBee. Since the same radios work fine with my Arduino Uno, I don't know if the problem is with the ArbotiX or if there is some special setting I need on the radios to work with the ArbotiX?

Thanks!
patrick

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2012-03-04 17:49:48

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-11-25 07:56:05 -0500

fergs gravatar image

The arbotix_python stuff hasn't been heavily tested over xbee. My first suggestion would be to try increasing the timeout in driver.py, as everything is currently optimized for 115k and low latency (which the XBEE at 57600 has neither). If that fixes the problem, we can expose the timeout as a parameter which could be set.

edit flag offensive delete link more

Comments

Thanks Fergs--I found the timeout parameter in arbotix.py rather than driver.py. I set it to 2.0 seconds rather than the default 0.1 but that did not fix the problem. I then set my XBee radios to 115200 baud and the Packetization Timeout to 0 and still no joy.
Pi Robot gravatar imagePi Robot ( 2011-11-25 10:27:36 -0500 )edit

@Pi Robot any updates on getting this working?

tfoote gravatar imagetfoote ( 2012-03-02 09:33:13 -0500 )edit

@tfoote No updates at this point--my ArbotiX is tucked away inside Pi Robot at the moment running the ArbotiX firmware instead of rosserial...

Pi Robot gravatar imagePi Robot ( 2012-03-03 12:51:50 -0500 )edit

Closing as this can't easily be verified.

tfoote gravatar imagetfoote ( 2012-03-04 17:49:41 -0500 )edit

I've just run into this exact issue. Setting the baud rate to 38400 (note you have to do this in both the firmware and the driver node) and the timeout to 2 seconds allowed communication over the XBees to work.

Brian Kohan gravatar imageBrian Kohan ( 2014-05-14 14:04:02 -0500 )edit

Question Tools

Stats

Asked: 2011-11-25 01:54:44 -0500

Seen: 438 times

Last updated: Nov 25 '11