Ask Your Question
0

ros_lib not created installing arduino [closed]

asked 2013-12-14 09:10:26 -0600

richkappler gravatar image

updated 2013-12-14 09:11:13 -0600

running a fresh install of hydro on a fresh install of ubuntu Precise. According to the tutorial at http://wiki.ros.org/rosserial_arduino/Tutorials/Arduino%20IDE%20Setup

under 3.3 Install ros_lib into the Arduino Environment

"The preceding installation steps created ros_lib, which must be copied into the Arduino build environment to enable Arduino programs to interact with ROS."

ros_lib was not created. any ideas? I rechecked everything in the install, all is well, no error messages etc.

Also, it says to put ros_lib in the libraries folder of the sketchbook. My libraries are at /usr/share/arduino/libraries

Does it matter?

regards, Richard

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by richkappler
close date 2013-12-28 08:08:09

1 Answer

Sort by » oldest newest most voted
4

answered 2013-12-15 13:40:17 -0600

updated 2014-02-28 07:00:54 -0600

The ros_lib should be installed in your Arduino "sketchbook/libraries". To install the ros_lib in the sketchbook use rosrun rosserial_arduino make_libraries.py <sketchbook>/libraries/ . You will have to make the libraries folder and the sketchbook should automatically be generated in the home directory after the Arduino IDE is opened once.

edit flag offensive delete link more

Comments

it should be rosrun and not ros

uzair gravatar imageuzair ( 2014-02-27 14:13:30 -0600 )edit

Sorry, you are correct.

tonybaltovski gravatar imagetonybaltovski ( 2014-02-28 07:00:44 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2013-12-14 09:10:26 -0600

Seen: 1,628 times

Last updated: Feb 28 '14