Ask Your Question
0

turtlebot_node/cmd_vel electric

asked 2011-11-23 00:15:47 -0600

apalomer gravatar image

Hi, In electric the problem that some nodes publish or subscribe turtlebot_node/cmd_vel or cmd_vel is supposed to be solved, but when I do sudo service turtlebot start the turtlebot node keeps listening to turtlebot_node/cmd_vel instead of cmd_vel. I've been reeding the code but I can't see where's the problem, there's no remap and where the listener is defined it doesn't have ~ in front, so it's supposed to listen to cmd_vel. Actually, if I ran a roscore and then rosrun turtlebot_node turtlebto_node.py it listens to the correct node. How can I fix it?

Thanks.

edit retag flag offensive close merge delete

Comments

did you update your bashrc, are you actually running the electric code or are you still running diamondback. Try env | grep ROS to see what path you are actually running from.
mmwise gravatar imagemmwise ( 2011-11-26 10:26:57 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-02-20 18:51:10 -0600

fergs gravatar image

It sounds like your upstart scripts probably haven't been upgraded from diamondback to Electric. I suggest doing the following:

roscd turtlebot_bringup/upstart
sudo ./install.bash <iface>

where <iface> is the name of your ethernet interface (usually wlan0 on most turtlebots).

edit flag offensive delete link more
0

answered 2012-02-16 07:46:39 -0600

mmwise gravatar image

did you update your bashrc, are you actually running the electric code or are you still running diamondback. Try env | grep ROS to see what path you are actually running from.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-11-23 00:15:47 -0600

Seen: 870 times

Last updated: Feb 20 '12