Ask Your Question
2

Require Help using ROSARIA

asked 2011-11-15 19:54:15 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi all, I am totally new to ROS, I know really little about it. I have a task of using ROSARIA to run my pioneer robot.

Initially I also had the problem of Installing the package, but I tried doing

$ sudo rosinstall /opt/ros//electric/ 'http://www.ros.org/wiki/ROSARIA/Tutorials/How%20to%20use%20ROSARIA?action=AttachFile&do=get&target=amor-ros-pkg.rosinstall'

I saw it got installed.

when I run rosmake ROSARIA I get the following error:

[ rosmake ] Packages requested are: ['ROSARIA'] [ rosmake ] Logging to directory/home/mycomp/.ros/rosmake/rosmake_output-20111115-194506 [ rosmake ] Expanded args ['ROSARIA'] to: [] [ rosmake ] WARNING: The following args could not be parsed as stacks or packages: ['ROSARIA'] [ rosmake ] ERROR: No arguments could be parsed into valid package or stack names.

then I noticed that in my folder I had a file ".hgignore" missing in the installed in directory(when compared to the files here: "https://amor-ros-pkg.googlecode.com/hg/"), I tried to create but as it has no name I couldn't, I am not sure If i am doing the right thing and is that file needed ?? rest all the files were proper.

Need help in this regard.

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
4

answered 2011-11-16 01:53:04 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi Puneeth, Actually i installed the ROSARIA with some difficulty couple of months back in my desktop (with diamondback). Now i am using another system (with electric) where i managed to install ROSARIA today to check your errors.

Here is the procedure that i followed First configure the workspace of ROS with the help of the following tutorials. Do not use the main installation stack path which is /opt/ros/electric.. http://www.ros.org/wiki/ROS/Tutorials/InstallingandConfiguringROSEnvironment

Check with the following command to see if the new workspace appears with the following command.

echo $ROS_PACKAGE_PATH

And after configuring go into your new workspace and checkout the amor-ros-pkg, wg-ros-pkg, ros-pkg manually to it. (I see some issues with the rosinstall way of installation so i do it this way) For amor-ros-pkg

hg clone https://amor-ros-pkg.googlecode.com/hg hg

For wg-ros-pkg (where you don't need all packages that are their in this repo)

a) For teleop_base

svn co https://code.ros.org/svn/wg-ros-pkg/branches/trunk_cturtle/sandbox/teleop_base teleop_base

b) For control_toolbox

svn co https://code.ros.org/svn/wg-ros-pkg/stacks/pr2_controllers/branches/pr2_controllers-1.4/control_toolbox control_toolbox

c) For joystick_drivers (ros-pkg has this only) You can use

sudo apt-get install ros-electric-joystick-drivers

Till here you have just checked out the source for rosaria, teleop_base and its dependencies in side the new workspace and installed joystick_drivers.

Now

cd hg/ROSARIA
cmake .
make

you can also do

rosmake ROSARIA

similarly go into the control_toolbox and followed by teleop_base (as this requires control_toolbox already) and do the

cmake .
make

Now you can also do

rosmake teleop_base

After this you are done with the ROSARIA installation along with teleop_base to do operate it from the keyboard.

Even i am a starter in ROS. I believe the rosinstall method that was given in the tutorial was to make life simpler than doing these many checkouts and installing them. But its not working due to the path clashes. If anyone has any other better way of explaining, pls do so.

Hope this helps Karthik

edit flag offensive delete link more
0

answered 2012-04-27 10:01:40 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hey Hi,

I tried your method but I get the following error:

user@ubuntu:~$ hg clone https://amor-ros-pkg.googlecode.com/hg/ abort: error: http://www.w3.org/TR/html4/strict.dtd">

Any idea?

edit flag offensive delete link more

Comments

I just checked, it works fine n i am able to download the hg package. Please try again and check your proxy if any.

karthik gravatar imagekarthik ( 2012-04-27 12:18:45 -0600 )edit
0

answered 2012-03-26 10:56:36 -0600

ReedHedges gravatar image

updated 2012-03-26 10:58:16 -0600

They recently deleted a bunch of page attachments from the wiki for some technical reason. I'm putting the contents of the rosinstall files back and will include links in it later as well.

However, I think Karthik's answer above will work just as well if not better (since the ROSARIA tutorial is still based on the previous Diamondback version of ROS, and hasn't yet been updated for the newer Electric version, though I hope to finish doing that at some point relatively soon).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-11-15 19:54:15 -0600

Seen: 1,210 times

Last updated: Apr 27 '12