ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

rosserial failed under Ubuntu 11.10 ROS electric [closed]

asked 2011-11-10 10:04:38 -0500

bona gravatar image

I was trying rosseial with Arduino based IR range finder. Ubuntu 11.10 ROS electric

The details is as below:

[INFO] [WallTime: 1320969440.580833] ROS Serial Python Node [INFO] [WallTime: 1320969440.584986] Connected on /dev/ttyUSB0 at 57600 baud [ERROR] [WallTime: 1320969442.700559] Creation of publisher failed: unpack requires a string argument of length 4 [ERROR] [WallTime: 1320969442.718333] Tried to publish before configured, topic id 125 [ERROR] [WallTime: 1320969442.777416] Tried to publish before configured, topic id 125 [ERROR] [WallTime: 1320969442.837355] Tried to publish before configured, topic id 125 [ERROR] [WallTime: 1320969442.896387] Tried to publish before configured, topic id 125

Anybody knows what's the problem? Thanks in advance.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by bona
close date 2015-06-24 10:10:07.699908


I've tried updating to the latest arduino 1.0.2 and the latest rosserial under electric with the same error.

DrBot gravatar image DrBot  ( 2012-12-10 05:55:45 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2011-11-10 11:37:09 -0500

fergs gravatar image

This looks like you upgraded the computer to rosserial 0.3.0, but did not update your Arduino libraries and/or re-upload the code to the Arduino. We recently added the md5 checksum to each topic negotiation so that users are alerted about changes in messages (which causes difficult to debug errors).

edit flag offensive delete link more

answered 2012-12-10 06:07:15 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I have the same error on 11.10 64bit machine. I've done a fresh install of Electric, rosserial and the 64bit arduino 1.0.2. Also the HelloWorld sketch will not compile unless I change the char declaration to unsigned char.

Specifically I am getting "A tried to publish before configured topic id 125" preceded by "unpack requires string arguement of length 4"

The same thing happens unde the 0022 IDE. (I do have to change the char to unsigned to compile.)

As far as I know the ros electric install is good, (turtlesim works)

edit flag offensive delete link more

Question Tools


Asked: 2011-11-10 10:04:38 -0500

Seen: 736 times

Last updated: Dec 10 '12