Ask Your Question
0

rosserial - lost sync with device (arduino)

asked 2011-09-13 05:07:11 -0600

Hi everyone,

I am experiencing some issues whith the rosserial_arduino tutorial "hello world" example. I am working on a ASUS eee PC with the latest ubuntu version (11.04) and a ROS release I installed during july 2011.

After installing the rosserial stack as described in the tutorial (http://www.ros.org/wiki/rosserial_arduino/Tutorials/Arduino%20IDE%20Setup), I was able to upload the "hello world" sketch into my arduino duemilanove.

Following the "hello world (example publisher)" page (http://www.ros.org/wiki/rosserial_arduino/Tutorials/Hello%20World), the issue appears in the terminal where I run the 'rosrun rosserial_python serial_node.py /dev/ttyUSB0' command :

me:$ rosrun rosserial_python serial_node.py /dev/ttyUSB0 [INFO] [WallTime:1315932634.660507] ROS Serial Python Node [INFO] [WallTime:1315932634.673866] Connected on /dev/ttyUSB0 at 57600 baud [ERROR] [WallTime:1315932664.690539] Lost sync with device, restarting... ... ...

Also as expected, when I try to listen to the topic with 'rostopic echo chatter', I have this warning message : WARNING: topic [/chatter] does not appear to be published yet

I was able to run a sketch with an IR sensor on the arduino in a standalone mode, so the communication between the computer and the arduino seems fine.

Did anyone already experience this 'sync' issue ? Is there any other way of checking the synchronisation between the arduino and ROS ?

Thanks a lot for anyhelp :) Dr. Frederic Villeneuve-Seguier

edit retag flag offensive close merge delete

Comments

1
Does your arduino duemilanove have a atmega168 or atmega328? If it is a 168, it is probably running out of memory. If so, check out this answer: http://answers.ros.org/question/2120/problem-setting-up-rosserial_arduino
adasta gravatar imageadasta ( 2011-09-14 01:44:55 -0600 )edit
Thanks a lot, following your advice I tried with an atmega 2560 I had and the sync problem disapeared right away.
Dr Frederic Villeneuve_Seguie gravatar imageDr Frederic Villeneuve_Seguie ( 2011-09-16 05:01:25 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-09-17 16:10:52 -0600

tfoote gravatar image

It looks like it was an out of memory error from comments above.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-09-13 05:07:11 -0600

Seen: 2,392 times

Last updated: Sep 17 '11