Ask Your Question
0

CMake with rosserial_arduino tutorial error

asked 2014-10-21 11:48:31 -0500

Robbie025 gravatar image

updated 2014-10-21 12:07:08 -0500

While doing the tutorial, i get the following error when i run catkin_make

-- ==> add_subdirectory(helloworld) CMake Error at helloworld/CMakeLists.txt:11 (rosserial_generate_ros_lib): Unknown CMake command "rosserial_generate_ros_lib". -- Configuring incomplete, errors occurred! Invoking "cmake" failed

What could be the problem?

I use ubuntu 12.04 with Hydro

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-10-22 02:35:21 -0500

kp gravatar image

updated 2014-11-19 05:25:59 -0500

I suggest you to check whether the content of ros-hydro-rosserial-arduino includes arduino-cmake files. I believe rosserial_generate_* CMake functions for arduino are defined in these files.

If file mentioned in comment is absent, try to add it in the place where CMake can find it. Maybe it will work.

edit flag offensive delete link more

Comments

Would be helpful if you include link to the exact tutorial with which you have a problem.

kp gravatar image kp  ( 2014-10-22 02:37:59 -0500 )edit

https://github.com/ros-drivers/rosserial/blob/indigo-devel/rosserial_client/cmake/rosserial_client-extras.cmake

This file should be present in your system, and CMake should be able to find it.

I tried to find it in hydro-devel branch, but seems it's not there. So maybe tutorial is for Indigo.

kp gravatar image kp  ( 2014-10-22 02:43:27 -0500 )edit

I tried it in groovey and I coudn't compile it, but with indigo all go well.

pando85 gravatar image pando85  ( 2014-10-24 04:37:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-10-21 11:48:31 -0500

Seen: 377 times

Last updated: Nov 19 '14