ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Install ROS on Linux Mint 16

asked 2014-01-15 04:54:33 -0500

hunse gravatar image

updated 2014-01-28 17:06:39 -0500

ngrennan gravatar image

The next instalment in the ever-updating series of installation questions: Is it possible to install ROS on Linux Mint 16 (which is based off Ubuntu 13.10 Saucy)? I've tried using the Raring packages, and (perhaps unsurprisingly) they don't work.

I've also tried installing from source (using this guide), encouraged by some forum posts suggesting that installing from source should work on Ubuntu Saucy. I run into problems when I get to the step that attempts to install the dependencies (rosdep install --from-paths src --ignore-src --rosdistro hydro -y). Specifically, I get ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies, followed by the list of dependencies paired with the message Unsupported OS [mint]. Is there any way to get around this?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2014-01-15 05:05:25 -0500

dornhege gravatar image

For this specific step setting ROS_OS_OVERRIDE might help you get further. Basically rosdep doesn't know mint. Just tell it to assume it's ubuntu and hope it works.

edit flag offensive delete link more

answered 2014-01-15 10:13:18 -0500

hunse gravatar image

Thanks @dornhege, that definitely got me going in the right direction! I ended up using the command rosdep install --from-paths src --ignore-src --rosdistro hydro -y --os=ubuntu:saucy (note the addition of --os=ubuntu:saucy) to do exactly what you suggested.

For other people installing on Linux Mint 16 (or Ubuntu Saucy), there were a few other things I had to do:

  1. Remove shiboken (and libshiboken*)
  2. Fix my /usr/lib/x86_64-linux-gnu/ to point to /usr/lib/

Also, I did not get the Desktop-Full install working (just Desktop), since gazebo was giving me problems (this might be fixable by following the Debian suggestions).

edit flag offensive delete link more


Hey, please can you help me in something?. I can't install ROS, I have linux mint 16, I've tried install from source but when I try to do the step 1 of the guide $ sudo apt-get install python-rosdep python-rosinstall-generator python-wstool python-rosinstall build-essential it tells me those package haven't been found. Well, I've already added the from wget -O - | sudo apt-key add - but it don't work :( please help me

fercarvo gravatar image fercarvo  ( 2014-01-23 06:47:06 -0500 )edit

The key is just to verify the repositories, you still have to add the repos themselves to your sources list. Check out step 1.2 in the [Ubuntu install directions](, and add the sources for Ubuntu 13.04 Raring.

hunse gravatar image hunse  ( 2014-01-23 08:02:01 -0500 )edit

@fercarvo Please open a new question. This seems to be a different problem.

dornhege gravatar image dornhege  ( 2014-01-24 00:12:30 -0500 )edit

answered 2014-03-31 02:17:51 -0500

tushis gravatar image
edit flag offensive delete link more

Question Tools



Asked: 2014-01-15 04:54:33 -0500

Seen: 10,237 times

Last updated: Mar 31 '14