Ask Your Question
1

How to merge git forks with current ROS directories? Camera_pose errors

asked 2014-01-13 09:22:26 -0600

Athoesen gravatar image

updated 2016-10-24 08:35:38 -0600

ngrennan gravatar image

Since camera_pose_calibration was never updated, I finally got the patched version of camera_pose from Github via this:

$ git clone <a href="https://github.com/jbohren-forks/camera_pose.git">https://github.com/jbohren-forks/camera_pose.git</a>

Unfortunately I'm not allowed to modify the files in ROS directories. I figured out that I would refer to the folder I put it in over the original ROS camera_pose folder by listing it first in ROS_PACKAGE_PATH but I'm still getting errors. How would I eliminate the old camera_pose folder? Using ROS Hydro right now.

Edit 1: After following the overlay instructions and using roscd to check that camera_pose is being looked at in my testspace first (it is), I'm encountering new errors.

This white text

terminate called after throwing an instance of 'pluginlib::LibraryLoadException'
what(): rospack could not find the image_transport package containing image_transport::PublisherPlugin

Followed by this red text

[kinect_1/stereo_cb_detector-2] process has died [pid 3069, exit code -6, cmd /opt/ros/fuerte/stacks/calibration/image_cb_detector/bin/image_cb_detector_action image:=image_throttle camera_info:=camera_info __name:=stereo_cb_detector __log:=/home/robot2/.ros/log/6b38aca2-7e0e-11e3-8b67-b8ca3a789964/kinect_1-stereo_cb_detector-2.log].

This error shows for all 3 Kinects.

Another white error

/home/robot2/Desktop/Testspace/src/camera_pose/camera_pose_calibration/src/camera_pose_calibration/multicam_capture_exec.py", line 43, in <module>
    from camera_pose_calibration.robot_measurement_cache import RobotMeasurementCache
ImportError: No module named camera_pose_calibration.robot_measurement_cache

Followed by red error

[capture_exec-19] process has died [pid 3315, exit code 1, cmd /home/robot2/Desktop/Testspace/src/camera_pose/camera_pose_calibration/src/camera_pose_calibration/multicam_capture_exec.py kinect_1 kinect_2 kinect_3 request_interval:=interval_filtered __name:=capture_exec __log:=/home/robot2/.ros/log/6b38aca2-7e0e-11e3-8b67-b8ca3a789964/capture_exec-19.log].
log file: /home/robot2/.ros/log/6b38aca2-7e0e-11e3-8b67-b8ca3a789964/capture_exec-19*.log

And a white message

ImportError: No module named camera_pose_calibration.msg

Then a bunch of angry red text. Any ideas? I also have included the roswtf output:

ERROR Could not contact the following nodes: * /kinect_2/stereo_cb_detector * /kinect_3/stereo_cb_detector * /kinect_1/stereo_cb_detector

ERROR The following nodes should be connected but aren't: * /kinect_3/stereo_cb_detector->/rosout (/rosout) * /kinect_1/stereo_cb_detector->/rosout (/rosout) * /kinect_2/stereo_cb_detector->/rosout (/rosout)

And for all three:

ERROR Errors connecting to the following services: * service [/kinect_2/stereo_cb_detector/set_logger_level] appears to be malfunctioning: Unable to communicate with service [/kinect_2/stereo_cb_detector/set_logger_level]

ERROR Errors connecting to the following services: * service [/kinect_2/stereo_cb_detector/get_loggers] appears to be malfunctioning: Unable to communicate with service [/kinect_2/stereo_cb_detector/get_loggers]

Any ideas?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-01-13 13:11:50 -0600

If I understand your question, I think you should clone this fork into your workspace source folder(your_ws/src/) and source the setup file found in your_ws/devel/setup.bash. This will overlay the fork package over the original package.

edit flag offensive delete link more

Comments

2

http://wiki.ros.org/catkin/Tutorials/workspace_overlaying

felix k gravatar imagefelix k ( 2014-01-13 22:04:04 -0600 )edit

I found this incredibly helpful. Unfortunately now it's producing different errors. I'm not sure if they're from it, or just ones that were hidden by previous errors.

Athoesen gravatar imageAthoesen ( 2014-01-15 06:19:06 -0600 )edit

Did you execute `catkin_make` on your workspace? it seems like can't find camera_pose_calibration message

gustavo.velascoh gravatar imagegustavo.velascoh ( 2014-01-15 08:16:01 -0600 )edit
1

Yes, I followed the directions. It's still throwing me errors. I've tried both sourcing the workspace under my Groovy sourcing in the .bashrc file, and also just doing it from terminal window. Each time I get TONS of errors from camera_pose_calibration, moreso than without trying to overlay.

Athoesen gravatar imageAthoesen ( 2014-01-15 08:41:43 -0600 )edit

Have you solved the errors? I am getting the same errors

simaopp gravatar imagesimaopp ( 2017-11-10 10:39:00 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-01-13 09:22:26 -0600

Seen: 275 times

Last updated: Jan 15 '14