Ask Your Question
0

rosjava on Ubuntu-USB-stick [closed]

asked 2011-10-23 20:47:16 -0600

gimili gravatar image

updated 2014-01-28 17:10:38 -0600

ngrennan gravatar image

Hi there!

I've tried to install and run rosjava on a Ubuntu 10.04 USB-Stick. newest versions of ros electric, eclipse and jdk are installed

The rosjava installation (into the stacks-folder) finished without error (also tried several reinstalls)

When I run rosmake (e.g. in the pubsub tutorial) it never finishes (Task 27/28 runs for hours, counting seconds but not finishing)

I even tried to copy the entire ros-directory the local harddrive and to change the $ROS_PACKAGE_PATH and running it there. No changes at all.

When I abort the making (ctrl+c) it throws this error:

rosrun rosjava_bootstrap generate_properties.py rosjava_tutorial_pubsub > ros.properties if [ ! -f .project ] ; then sed s/PROJECT_NAME/rosjava_tutorial_pubsub/ rospack find rosjava_bootstrap/eclipse/eclipse-project-template > .project ; touch .project-generated; fi if [ ! -f .classpath ] ; then rosrun rosjava_bootstrap generate_properties.py --eclipse rosjava_tutorial_pubsub > .classpath ; touch .classpath-generated; fi rosrun rosjava_bootstrap generate_msg_depends.py rosjava_tutorial_pubsub [rosrun] You have chosen a non-unique executable, please pick one of the following: 1) /media/DATA/ros_test/ros/electric/stacks/rosjava_core/rosjava_bootstrap/scripts/generate_msg_depends.py 2) /media/DATA/ros_test/ros/electric/stacks/rosjava_core/rosjava_bootstrap/src/main/python/rosjava_bootstrap/generate_msg_depends.py

any ideas?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by damonkohler
close date 2012-01-27 04:01:54

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-10-27 00:11:10 -0600

damonkohler gravatar image

That definitely looks like a bug. I guess it's a problem with the distribution though. rosjava_bootstrap/scripts/generate_msg_depends.py does not exist. Maybe try installing rosjava from source?

edit flag offensive delete link more

Comments

We tried this already, with no luck. As a workaround we changed the setup now, so that we are not booting ubuntu from a usb-stick but running it directly in a virtual box (so we can take the VM to other computers)
gimili gravatar imagegimili ( 2011-10-27 00:37:12 -0600 )edit

Question Tools

Stats

Asked: 2011-10-23 20:47:16 -0600

Seen: 207 times

Last updated: Oct 27 '11