Ask Your Question
1

how to update ROS_PACKAGE_PATH ?

asked 2011-10-22 02:33:45 -0500

abrsefid gravatar image

updated 2011-10-22 06:14:01 -0500

tfoote gravatar image

farshid@ubuntu:~$ roscreate-pkg farshid

WARNING: current working directory is not on ROS_PACKAGE_PATH!
Please update your ROS_PACKAGE_PATH environment variable.

how update ROS_PACKAGE_PATH ?

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
10

answered 2011-10-22 02:56:19 -0500

This is described in the tutorial Installing and Configuring Your ROS Environment.

edit flag offensive delete link more

Comments

if after configuring your environment, still the ros commands like (ros_make) doesn't work than go to .bashrc file & remove all the duplicate lines at the bottom. than follow the instruction mentioned by Dan Lazewatsky.

aly gravatar imagealy ( 2014-09-30 09:24:48 -0500 )edit
1

answered 2011-10-22 11:23:48 -0500

gavinmachine gravatar image

Use this syntax on the command line:

export ROS_PACKAGE_PATH=~/ros_workspace:/opt/ros/electric/stacks

Replace "~/ros_workspace:/opt/ros/electric/stacks" with the desired package path.

edit flag offensive delete link more
0

answered 2011-10-24 03:06:08 -0500

sam gravatar image

I prefer just edit ~/.bashrc file to set ROS_PACKAGE_PATH. After edit that file,remember to restart terminal or create new one.

edit flag offensive delete link more
0

answered 2013-10-10 23:51:58 -0500

Use:

rosws set ~/fuerte_workspace/package_name

where in your case package_name is farshid. To know what's your fuerte_workspace use:

echo $ROS_WORKSPACE

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-10-22 02:33:45 -0500

Seen: 17,513 times

Last updated: Oct 10 '13