Ask Your Question
1

rosrun rviz failed in Groovy

asked 2013-01-06 11:06:38 -0500

chenling34401 gravatar image

updated 2013-01-07 04:59:32 -0500

joq gravatar image

Hi,

I upgraded my Ubuntu from 11.10 to 12.04 by using "update manager", and in updated 12.04, I installed Groovy using commands "sudo apt-get update" and "sudo apt-get install ros-groovy-desktop-full". There were not any errors during the installation. However, my entering "rosrun rviz rviz" in the terminal leads to:

[ INFO] [1357508126.785180749]: rviz version 1.9.18
[ INFO] [1357508126.785299200]: compiled against OGRE version 1.7.4 (Cthugha)
ImportError: No module named rospack
[rospack] Error: could not find python module 'rosdep2.rospack'. is rosdep up-to-date (at least 0.10.4)?
[librospack]: error while executing command
terminate called after throwing an instance of 'pluginlib::LibraryLoadException'
  what():  rospack could not find the rviz package containing rviz::Panel
Aborted (core dumped).

Any one who can help me out? Thanks.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
3

answered 2013-01-06 11:26:29 -0500

KruseT gravatar image

updated 2013-01-07 05:25:16 -0500

As the error says, check your rosdep version. It gets installed separately as python-rosdep. See: http://www.ros.org/wiki/groovy/Installation/Source

Not sure whether that will also help with the rviz problem.

EDIT: It is possible that there is a conflict with a previous version of rosdep installed via pip or easy_install. You should removed that one, if that's the case.

$ sudo pip uninstall rosdep

if that fails, you can fall back to:

$ sudo rm -rf /usr/local/lib/python2.7/dist-packages/rosdep*
edit flag offensive delete link more

Comments

Thanks, as you suggested, I tried "sudo apt-get install python-rosdep python-wstool build-essential", and rosdep was successfully installed. But the same problem remained. However, I tried installing ros fuerte and "rosrun rviz rviz" worked well for fuerte. I am still struggled.

chenling34401 gravatar image chenling34401  ( 2013-01-06 22:54:35 -0500 )edit

i was getting the same error you were and "sudo pip uninstall rosdep" then "sudo apt-get install python-rosdep python-wstool build-essential" fixed it for me and "rosrun rviz rviz" works . I'm running ubuntu 12.04 and groovy.

nickd gravatar image nickd  ( 2013-01-07 19:03:02 -0500 )edit
0

answered 2013-01-07 07:45:11 -0500

chenling34401 gravatar image

updated 2013-01-07 07:46:49 -0500

Thanks. I tried "sudo pip uninstall rosdep" and the rosdep was removed successfully, as files in the directory "/usr/local/lib/python2.7/dist-packages" disappeared.

However, the command "rosrun rviz rviz" still leads to the following errors:

Traceback (most recent call last): File "/usr/lib/pymodules/python2.7/rosdep2/rospack.py", line 55, in init_rospack_interface lookup = _get_default_RosdepLookup(Options()) File "/usr/lib/pymodules/python2.7/rosdep2/main.py", line 108, in _get_default_RosdepLookup lookup = RosdepLookup.create_from_rospkg(sources_loader=sources_loader) File "/usr/lib/pymodules/python2.7/rosdep2/lookup.py", line 319, in create_from_rospkg lookup._load_all_views(loader=sources_loader) File "/usr/lib/pymodules/python2.7/rosdep2/lookup.py", line 464, in _load_all_views self._load_view_dependencies(resource_name, loader) File "/usr/lib/pymodules/python2.7/rosdep2/lookup.py", line 486, in _load_view_dependencies loader.load_view(view_key, db, verbose=self.verbose) File "/usr/lib/pymodules/python2.7/rosdep2/sources_list.py", line 525, in load_view rosdep_db.set_view_data(view_name, source.rosdep_data, view_dependencies, view_name) File "/usr/lib/pymodules/python2.7/rosdep2/model.py", line 89, in set_view_data self._rosdep_db[view_name] = RosdepDatabaseEntry(rosdep_data.copy(), view_dependencies, origin) AttributeError: 'NoneType' object has no attribute 'copy'

[rospack] Error: could not call python function rosdep2.rospack.init_rospack_interface'

terminate called after throwing an instance of 'pluginlib::LibraryLoadException' what(): rospack could not find the rviz package containing rviz::Panel Aborted (core dumped)

edit flag offensive delete link more
0

answered 2013-02-03 12:31:16 -0500

sudo chmod -R 777 /home/USER//ros/*

it was a permissions issue for me.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-01-06 11:06:38 -0500

Seen: 2,016 times

Last updated: Feb 03 '13