Ask Your Question
0

Serial ID in two of my Kinects set to "0000...", how do I fix this and is it a problem moving forward with calibration?

asked 2014-01-07 10:44:59 -0600

Athoesen gravatar image

updated 2016-10-24 09:10:29 -0600

ngrennan gravatar image

So I understand that this was an issue with some Kinects but I didn't think the 1473 models had this problem. When I first started using them I remember each had a distinct serial ID. But now when I launch one and it gives me the readout of devices connected this is what happens:

[ INFO] [1389133766.386762473]: Number devices connected: 3
[ INFO] [1389133766.386864325]: 1. device on bus 003:10 is a SensorV2 (2ae) from PrimeSense (45e) with serial id 'A00367A05655114A'
[ INFO] [1389133766.386900866]: 2. device on bus 001:08 is a SensorV2 (2ae) from PrimeSense (45e) with serial id '0000000000000000'
[ INFO] [1389133766.386928332]: 3. device on bus 002:11 is a SensorV2 (2ae) from PrimeSense (45e) with serial id '0000000000000000'
[ INFO] [1389133766.388238717]: Searching for device with bus@address = 2@0

Currently I'm trying to calibrate them so that I can use camera_pose_calibration but the problem is that as stated in the intrinsic calibration tutorial the calibrations are stored based on serial number.

depth_B00362708888047B.yaml  rgb_B00362708888047B.yaml

I'm assuming this might not cause problems making everything run but it WILL override the calibration for my 2nd or 3rd Kinect based on whichever was saved last to that filename.

Anyone have any ideas on how to fix this? Running Hydro.

Edit: So I just noticed right below the 0000 serial number it says this-

[ INFO] [1389137117.588627159]: Opened 'SensorV2' on bus 2:11 with serial number 'A00367A05655114A'

Now I'm truly confused as to whether it is recognizing it or not.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-01-08 05:07:13 -0600

Athoesen gravatar image

updated 2014-01-08 05:29:38 -0600

Nevermind. It appears I missed a memo about the new 1473 models having no serial number whereas my 3rd Kinect was (a surprise to me) a 1414 model.

Issues between the two models discussed here: http://answers.ros.org/question/61542/kinect-xbox360-new-model-1473-has-problems-example-serial-number-soundcard/

edit flag offensive delete link more

Comments

Athoesen, were you able to get a new driver installed to recognize the serial number? I'm in your exact same boat with calibration and I really dont want to try a bunch different drivers to get this working. Can you suggest a solution? freenect_stack or Openni2?

TFinleyosu gravatar imageTFinleyosu ( 2014-03-19 05:34:03 -0600 )edit

No. My advisor ended up trading me her family's 1414 for one of the 1473's. That serial number issue seems to be a sticking point. I tried to see if you could manually assign one or choose the name for saving but no one answered.

Athoesen gravatar imageAthoesen ( 2014-03-20 16:50:15 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-01-07 10:44:59 -0600

Seen: 822 times

Last updated: Jan 08 '14