Ask Your Question

Kinect not detected

asked 2011-10-06 08:10:50 -0600

karthik gravatar image

Hi, I previously posted an issue regarding errors in openni drivers installation ( With the answer to this question i was able to install the drivers successfully. Then i ran the openni_camera node's openni_node.launch file, which says the devices is not connected.

aravindhan@rrc-laptop:~$ roslaunch openni_camera openni_node.launch
... logging to /home/aravindhan/.ros/log/a30405ca-f056-11e0-83fc-5c260a051546/roslaunch-rrc-laptop-22434.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://rrc-laptop:42441/


 * /rosdistro
 * /openni_node1/use_indices
 * /openni_node1/depth_registration
 * /openni_node1/image_time_offset
 * /openni_node1/depth_frame_id
 * /openni_node1/depth_mode
 * /openni_node1/debayering
 * /rosversion
 * /openni_node1/projector_depth_baseline
 * /openni_node1/rgb_frame_id
 * /openni_node1/depth_rgb_translation
 * /openni_node1/depth_time_offset
 * /openni_node1/image_mode
 * /openni_node1/shift_offset
 * /openni_node1/device_id
 * /openni_node1/depth_rgb_rotation

    openni_node1 (openni_camera/openni_node)
    kinect_base_link (tf/static_transform_publisher)
    kinect_base_link1 (tf/static_transform_publisher)
    kinect_base_link2 (tf/static_transform_publisher)
    kinect_base_link3 (tf/static_transform_publisher)

auto-starting new master
process[master]: started with pid [22450]

setting /run_id to a30405ca-f056-11e0-83fc-5c260a051546
process[rosout-1]: started with pid [22463]
started core service [/rosout]
process[openni_node1-2]: started with pid [22473]
process[kinect_base_link-3]: started with pid [22476]
process[kinect_base_link1-4]: started with pid [22477]
process[kinect_base_link2-5]: started with pid [22478]
process[kinect_base_link3-6]: started with pid [22479]
[ INFO] [1317931571.886741090]: [/openni_node1] No devices connected.... waiting for devices to be connected
[ INFO] [1317931572.887058521]: [/openni_node1] No devices connected.... waiting for devices to be connected
[ INFO] [1317931573.887393253]: [/openni_node1] No devices connected.... waiting for devices to be connected
[ INFO] [1317931574.887772578]: [/openni_node1] No devices connected.... waiting for devices to be connected
[ INFO] [1317931575.888150279]: [/openni_node1] No devices connected.... waiting for devices to be connected

What possibly could be wrong here?

Thanks in advance, Karthik

edit retag flag offensive close merge delete


Please post the output of "lsusb"
fergs gravatar image fergs  ( 2011-10-06 10:47:49 -0600 )edit

5 Answers

Sort by ยป oldest newest most voted

answered 2011-10-13 23:41:07 -0600

karthik gravatar image

Reinstalled Ubuntu 11.04 (32bit) installed ROS electric and everything else. Now started getting the pointcloud from Kinect in rviz. Hope this is not the solution to the question but since I couldn't find much help on this, I had to go this way. So this is one of the solution to the problem.

Thanks Karthik

edit flag offensive delete link more

answered 2011-12-12 01:59:58 -0600

Same problem here with ubuntu 10.04, it seems to be an issue with the libusb-1.0-0-dev or the openni-dev libraries...

The solution was to re-install the dependecies of the openni_kinect stack

First unistall the OpenNI developer package

$ sudo apt-get remove openni-dev libusb-1.0-0-dev

and reinstall it afterwards

$ sudo apt-get install openni-dev libusb-1.0-0-dev

Then recompile the package usign the --rosdep-install and --pre-clean options

$ rosmake openni_ros --rosdep-install --pre-clean

Let me know if it works for you...



edit flag offensive delete link more


thanks mario; but i am not able to check it now as things are working fine for me after the new installation.
karthik gravatar image karthik  ( 2011-12-14 06:59:32 -0600 )edit

answered 2012-02-10 06:18:43 -0600

brianpen gravatar image

Adding my own notes from troubleshooting...

Sometimes it can also be a power problem. Check to make sure the connect turlebot adapter (or wall adapter) is plugged in and the green light on the connector is on. Verify the icreate base is on.

Try an lsusb. You should see 3 devices from "Microsoft Corp". If you only see one, the kinect may not have full power.

edit flag offensive delete link more

answered 2011-12-13 04:05:43 -0600

I've had this problem before and solved it by killing the XnSensorServer.

killall XnSensorServer
edit flag offensive delete link more

answered 2011-10-06 08:18:09 -0600

Daniel Canelhas gravatar image

Does it work better if you start each node separately?



then, in another terminal

rosrun openni_camera openni_node
edit flag offensive delete link more


No its not working that way either.
karthik gravatar image karthik  ( 2011-10-06 10:12:34 -0600 )edit
Does the device show up if you do lsusb in terminal (add -v or -vv for more verbose output)?
Daniel Canelhas gravatar image Daniel Canelhas  ( 2011-10-06 11:39:08 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2011-10-06 08:10:50 -0600

Seen: 4,421 times

Last updated: Feb 10 '12