Ask Your Question
0

Turtlebot amcl demo, using map-files from selected directory?

asked 2011-09-29 03:51:15 -0600

hfor gravatar image

map files created with the turtlebot 'SLAM map building' tutorial are stored in the /tmp/ directory. I have tried moving the generated files to my home directory and the run the 'amcl-navigation demo' pointing to the files in this directory but the map-server does'nt seem to accept this. How can i store and reuse different mapfiles?

roslaunch turtlebot_navigation amcl_demo.launch map_file:=/turtlebot/freja02.yaml

HFOR

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2011-11-23 13:55:02 -0600

130s gravatar image

updated 2011-11-23 13:56:48 -0600

as @tfoote pointed out, the command should look like:

roslaunch turtlebot_navigation amcl_demo.launch map_file:=/home/turtlebot/freja02.yaml

Also, make sure your .yaml file points out the right location of .pgm file. Suppose you have freja02.pgm also in the home directory, you might want to something like:

emacs freja02.yaml &

This will open a text editor, then correct perhaps the 1st line where describes the path of .pgm file as:

image: /home/turtlebot/freja02.pgm

then save file by Ctrl-s (pressing control key and s). Close the window, and run the .launch file again.

edit flag offensive delete link more
1

answered 2011-09-29 05:19:44 -0600

tfoote gravatar image

When you move the map files do you move both the yaml and the binary file next to it? They yaml file is just the metainformation for the map.

Also if it's in your home directory it should be /home/turtlebot/freja02.yaml

edit flag offensive delete link more
0

answered 2011-09-30 03:45:48 -0600

hfor gravatar image

I move two files, the .yaml file and the corresponding .pgm file

I have tried the 'roslaunch turtlebot_navigation amcl_demo.launch map_file:=/home/turtlebot/freja02.yaml' path as well without success.

However, as long as the requested files are available in the /tmp/ directory, the command will run, regardless of whar path i point out in the roslaunch turtlebot_navigation amcl_demo.launch map_file:=/home/turtlebot/freja02.yaml command...

I still think this might be related to my limited skills in Linux...

HFOR

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-09-29 03:51:15 -0600

Seen: 1,645 times

Last updated: Nov 23 '11