Ask Your Question
0

TurtleBot gmapping and amcl demos FATAL footprint error for move_base

asked 2011-09-27 13:26:40 -0500

Pi Robot gravatar image

(Ticket 5185 submitted.)

Using the latest Electric debians for the TurtleBot stack, running either the gmapping or amcl demo throws a FATAL move_base error as follows:

[ INFO] [1317172658.105549257]: Received a 320 X 512 map at 0.050000 m/pix

[FATAL] [1317172658.745797230]: The footprint must be specified as list of lists on the parameter server, /move_base/global_costmap/footprint was specified as [] terminate called after throwing an instance of 'std::runtime_error'

    what(): The footprint must be specified as list of lists on the parameter server with at least 3 points eg: [[x1, y1], [x2, y2], ..., [xn, yn]]

[move_base-9] process has died [pid 25570, exit code -6]. log files: /home/patrick/.ros/log/63dc7caa-e95e-11e0-a56b-002163a7d4bb/move_base-9*.log
edit retag flag offensive close merge delete

Comments

Can you please post the version of navigation that you're running? This sounds like a bug that was fixed awhile ago so I'm wondering if you're up to date or if the debians didn't roll out properly somehow.
eitan gravatar imageeitan ( 2011-09-28 04:19:26 -0500 )edit
Patrick, I can't reproduce this with a fresh install of ros-electric-turtlebot-robot.
fergs gravatar imagefergs ( 2011-09-28 09:29:04 -0500 )edit
Thanks Eitan and Fergs. rosversion shows I have 1.6.3 of the navigation stack. I just tried the gmapping_demo again and got the same error. I did a fresh install of Electric yesterday before getting this error but I'll try it again just to be sure.
Pi Robot gravatar imagePi Robot ( 2011-09-28 10:11:50 -0500 )edit
Actually, I take that back... I failed to get the path right on my user account -- I'm now seeing this error.
fergs gravatar imagefergs ( 2011-09-28 10:43:14 -0500 )edit
Cool--at least it's not just me. :-)
Pi Robot gravatar imagePi Robot ( 2011-09-28 10:45:32 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-09-28 11:35:44 -0500

fergs gravatar image

OK, so this is a bug in the navigation stack. You probably notice that you only get this when you restart the launch file (it will work the first time). You can make it work again by doing:

rosparam delete move_base/local_costmap/footprint
rosparam delete move_base/global_costmap/footprint

Basically, the nav stack is storing the footprint calculations back onto the param server after parsing them, but because we don't specify a footprint (as we have a circular robot), we get an error. I'm working on a patch now.

edit flag offensive delete link more

Comments

Yeah, I was probably always re-launching because I would mess up some other way, Ctrl-C out of the launch and try again.
Pi Robot gravatar imagePi Robot ( 2011-09-28 11:46:36 -0500 )edit
OK, this is good to know. There was some code introduced to support dynamic reconfigure that is likely the culprit, I'll have a fix in a second.
eitan gravatar imageeitan ( 2011-09-28 12:56:29 -0500 )edit
So, things should be fixed in trunk now, I'll also push out a release once things get tested. Sorry for the trouble.
eitan gravatar imageeitan ( 2011-09-28 13:03:59 -0500 )edit
Navigation 1.6.4 has the fix, just a matter of time until the debs come out.
eitan gravatar imageeitan ( 2011-09-28 13:19:26 -0500 )edit
Many thanks Eitan. I was just in the process of testing it but have to head out the door--good to see that Fergs is still 10x faster than I am at this stuff. :-)
Pi Robot gravatar imagePi Robot ( 2011-09-28 13:21:33 -0500 )edit
Works like a charm now. Thanks!
Pi Robot gravatar imagePi Robot ( 2011-09-29 01:35:51 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-09-27 13:26:40 -0500

Seen: 808 times

Last updated: Sep 28 '11