Ask Your Question
3

Multiple errors launching openni.launch: "Tried to advertise a service that is already advertised in this node"

asked 2011-09-26 02:00:55 -0600

llqazs gravatar image

updated 2011-09-26 05:55:06 -0600

Hi,everybody! I entered "roslaunch openni_launch openni.launch" in the terminal, then I got the following response.

......
[ERROR] [1317043259.886787650]: Unable to open camera calibration file [/home/llq/.ros/camera_info/depth_A00364A05003107A.yaml]
[ WARN] [1317043259.886937571]: Camera calibration file /home/llq/.ros/camera_info/depth_A00364A05003107A.yaml not found.
[ WARN] [1317043259.889818576]: Using default parameters for RGB camera calibration.
[ WARN] [1317043259.889868600]: Using default parameters for IR camera calibration.
[ERROR] [1317043261.086826518]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/compressed/set_parameters]
[ERROR] [1317043261.134411949]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/theora/set_parameters]

I have been solving this problem all day long but I failed.

edit retag flag offensive close merge delete

Comments

The first two messages just warn that there is no calibration file in the default location. You probably need not worry about that. If you do calibrate the camera, the data will be stored there.
joq gravatar imagejoq ( 2011-09-26 06:59:18 -0600 )edit
I'm not sure if he/she's doing something special, but I believe the openni package is supposed to supply the camera calibration info.
Asomerville gravatar imageAsomerville ( 2011-09-26 07:01:07 -0600 )edit
llqazs, I'm not familiar wtih openni_launch/launch/openni.launch or why it might not work, but openni_camera/launch/openni_node.launch works for my purposes and might be worth trying.
Asomerville gravatar imageAsomerville ( 2011-09-26 07:07:13 -0600 )edit
Thank you joq. I can display the image with image_view, but once I use rviz to display PointCloud2 data, my computer crashed. And there was no information file saved in the camera_info folder.
llqazs gravatar imagellqazs ( 2011-09-27 01:45:24 -0600 )edit
Thank you Asomerville. I have tried to use openni_camera/launch/openni_node.launch, but the problem is that I can't use rviz to display PointCloud2 data. What should I do to make it successful?
llqazs gravatar imagellqazs ( 2011-09-27 01:49:33 -0600 )edit
try launching the file and then do a rostopic hz on the image and cloud topics. If it is publishing data then the node came up properly despite the error. I would then try to see if there are any orphaned processes that could be causing the error.
mmwise gravatar imagemmwise ( 2011-10-18 08:56:06 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-09-21 03:19:26 -0600

harsha gravatar image

updated 2012-09-21 06:33:43 -0600

Like joq said, you don't have to worry about the error message regarding the calibration file.

I had the same problem of "Tried to advertise a service that is already advertised in this node". A solution can be found here. The second answer explains the reason behind this error message and how to get rid of it.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-09-26 02:00:55 -0600

Seen: 4,817 times

Last updated: Sep 21 '12