ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Nothing published to /scan under Hydro

asked 2013-12-20 07:00:30 -0600

nsprague gravatar image

updated 2016-10-24 09:03:01 -0600

ngrennan gravatar image

After updating to Hydro, executing:

roslaunch turtlebot_bringup 3dsensor.launch

no longer seems to work correctly.

The expected topics appear, and it is possible to get some data off the Kinect: images and pointcloud data can be visualized in rviz. However, nothing is being published to the \scan topic.

Everything seems to work fine if I grab a copy of the Groovy version of 3dsensor.launch and launch that.

The issue is the same whether I use a Kinect or Asus Xtion.

Has anyone else had luck with 3dsensor.launch under Hydro?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2013-12-22 11:31:11 -0600

jihoonl gravatar image

/scan topic may not work with the default 3dsensor.launch setup.

Try this.

3dsensor.launch depth_registration:=false

edit flag offensive delete link more


Thanks! That solves the problem. Is there any reason this defaults to true? According to the documentation for openni_launch: "If true, use OpenNI's factory-calibrated depth->RGB registration", but it defaults to false for openni_launch. What is the practical impact of leaving it off?

nsprague gravatar image nsprague  ( 2013-12-30 03:29:10 -0600 )edit

It changes the type of output you get. With false, you get just depth clouds which are lower bandwidth and come out on a different topic. Changing it will break anyone using the old settings.

tfoote gravatar image tfoote  ( 2013-12-30 11:18:49 -0600 )edit

Good to know. I think this should be considered a bug in 3dsensor.launch. It will be confusing for users if different topics are "broken" based on a configuration setting. It's also inconsistent with the behavior in Groovy.

nsprague gravatar image nsprague  ( 2014-01-02 09:22:45 -0600 )edit

Create a ticket on github and when people have time they can check. I remember originally setting up 3dsensor.launch in groovy so everything was on and 'viewable' from rviz (but you shouldn't use it like this because it's cpu hungry), so it might be a regression.

Daniel Stonier gravatar image Daniel Stonier  ( 2014-01-02 20:59:03 -0600 )edit

nsprague gravatar image nsprague  ( 2014-01-03 02:49:27 -0600 )edit

I tried the solution above. when I use depth_registration=false, I don't get the PointCloud2 output on rviz.

SHPOWER gravatar image SHPOWER  ( 2014-01-15 22:15:48 -0600 )edit

answered 2013-12-20 07:24:03 -0600

BlitherPants gravatar image

Have you tried 'rostopic list' yet? I don't have Hydro, but it's possible there's a topic similar to '/scan' being published. If that were the case, you'd just need to remap the arguments in your launch file...

edit flag offensive delete link more


The /scan topic appears in the list of topics.

nsprague gravatar image nsprague  ( 2013-12-20 08:20:45 -0600 )edit

Right, probably because you have something subscribed to it and nothing publishing it (you can verify this with 'rostopic info /scan'). Is there anything else that has the word "scan" in it in the list of topics? Sorry if you've already done all this.

BlitherPants gravatar image BlitherPants  ( 2013-12-20 08:26:34 -0600 )edit

No, that's not what's happening. The /scan topic is definitely created by the launch file. I don't have the machine in front of me, so I can't show you the output of 'rostopic info /scan', but I have looked at it. The topic appears, but no data is ever published to it.

nsprague gravatar image nsprague  ( 2013-12-20 12:30:12 -0600 )edit

Question Tools

1 follower


Asked: 2013-12-20 07:00:30 -0600

Seen: 789 times

Last updated: Dec 22 '13