Ask Your Question
1

Why roscore can' find the good IP adress ?

asked 2011-09-08 01:33:35 -0500

Guido gravatar image

Hi all,

My computer has two IPv4 adresses (one for the wired lan, one for the wifi). The computer name is gilgamesh. Its name on the wired lan is gilgamesh too. But its name through wifi is gilgamesh-wifi. When I start roscore, with wifi on, it complains about not being able to ping gilgamesh (While it should try to ping gilgamesh-wifi).

How to specify the name of the host computer when launching roscore ? (or any ros server)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2011-09-08 02:00:12 -0500

dornhege gravatar image

set the ROS_HOSTNAME environment variable to the one you want.

edit flag offensive delete link more

Comments

Thank you. It works like a charm.
Guido gravatar imageGuido ( 2011-09-08 03:21:03 -0500 )edit
2

answered 2011-09-08 01:42:45 -0500

updated 2011-09-08 01:43:17 -0500

try setting your ROS_MASTER_URI env variable to: ROS_MASTER_URI=http://gilgamesh-wifi:11311

edit flag offensive delete link more

Comments

Thank you, this works, but i'd rather use ROS_MASTER_URI when dealing with remote computer.
Guido gravatar imageGuido ( 2011-09-08 03:22:39 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-09-08 01:33:35 -0500

Seen: 595 times

Last updated: Sep 08 '11