Ask Your Question
0

error creating ros_lib with groovy

asked 2013-12-15 15:31:55 -0500

getSurreal gravatar image

I'm not able to create the arduino library with groovy on either the Raspberry Pi or Ubuntu 12.04. When I switched to Hydro on Ubuntu I was able to create the library and plan to copy it over, but I'm not sure if there will be incompatibilities to try and use the hydro ros_lib while running groovy.

pi@raspbian ~/Arduino/libraries $ rosrun rosserial_arduino make_libraries.py .  
Exporting to .
Traceback (most recent call last):
  File "/opt/ros/groovy/share/rosserial_arduino/make_libraries.py", line 88, in <module>
    rosserial_client_copy_files(rospack, rosserial_arduino_dir+"/src/ros_lib/")
  File "/opt/ros/groovy/lib/python2.7/dist-packages/rosserial_client/make_library.py", line 580, in rosserial_client_copy_files
    shutil.copy(mydir+"/src/ros_lib/"+f, path+f)
  File "/usr/lib/python2.7/shutil.py", line 119, in copy
    copyfile(src, dst)
  File "/usr/lib/python2.7/shutil.py", line 83, in copyfile
    with open(dst, 'wb') as fdst:
IOError: [Errno 2] No such file or directory: '/opt/ros/groovy/share/rosserial_arduino/src/ros_lib/ros/duration.h'
edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2013-12-15 20:18:04 -0500

David Galdeano gravatar image

updated 2013-12-15 20:41:28 -0500

Hello, in http://wiki.ros.org/rosserial_arduino/Tutorials/Arduino%20IDE%20Setup follows the steps "3.2 Installing from Source onto the ROS workstation" and "3.3 Install ros_lib into the Arduino Environment" when you install rosserial on the raspberry pi.

Instalation from binaries is broken ("3.1 Installing Binaries on the ROS workstation"). This is due to https://github.com/ros-drivers/rosserial/issues/79 and have been fixed on sources but not in the raspbian build farm.

This works with rosserial/groovy/raspbian

edit flag offensive delete link more

Comments

Thank you for the response. It worked as you described.

getSurreal gravatar image getSurreal  ( 2013-12-17 13:01:38 -0500 )edit
1

answered 2014-01-13 03:29:52 -0500

David Galdeano gravatar image

You must create a sketchbook/libraries folder in your home folder. The rosrun rosserial_arduino make_libraries.py can be then executed to create ros_lib directory.

edit flag offensive delete link more

Comments

Thanks you so much

4LV4R0 gravatar image 4LV4R0  ( 2014-01-14 06:36:21 -0500 )edit
0

answered 2014-01-13 02:03:35 -0500

4LV4R0 gravatar image

updated 2014-01-13 02:22:01 -0500

Good afternoon partners.

After several attemps to regenerate ros_build I´m still having the same error messages I´m running ROS Groovy in a Raspberry Pi with raspbian.

Exporting to /home/pi/catkin_ws/src/rosserial/rosserial_arduino/src Traceback (most recent call last):

File "/home/pi/catkin_ws/src/rosserial/rosserial_arduino/src/rosserial_arduino/make_libraries.py", line 87, in <module> shutil.copytree(rosserial_arduino_dir+"/src/ros_lib", path+"/ros_lib")

File "/usr/lib/python2.7/shutil.py", line 171, in copytree names = os.listdir(src)

OSError: [Errno 2] No such file or directory: '/home/pi/catkin_ws/src/rosserial/rosserial_arduino/src/ros_lib'

I have followed the instructions as "galdeano" said above but I´m thinking that I´m doing someething wrong. I´m going to programm the Arduino on Windows

My question is , which folder ros_lib have I to delete before regenerate it?

I have one of them in /opt/ros/groovy/share/rosserial_arduino/src and the other one into /catkin_ws/src/rosserial/rosserial_arduino/src/ and the other one into /catkin_ws/install/share/rosserial_arduino/src/

I have created a new folder into my home called WindowsRos_Build where I want to regenerate my new ros_lib folder but as the tutorial says I have to delete first of all the existing ros_build folder.

Probably I´m doing something wrong... Could you help me please?

When I do : rosrun rosserial_arduino make_libraries.py . into my windows destinated folder I get the next report where I receive some messages with not founded packets and I´m worried about it:

Exporting to .

Exporting rosserial_msgs

Messages: Log,TopicInfo,

Services: RequestParam,RequestMessageInfo,

Exporting std_msgs

Messages: UInt32MultiArray,Int64,UInt8MultiArray,Float32,Int32MultiArray,UInt64,Int16, UInt16,Float64,Float32MultiArray,MultiArrayDimension,Duration,Float64MultiArray, Int32,UInt8,Int8,Int16MultiArray,Time,Byte,Bool,ByteMultiArray,UInt32,MultiArray Layout,UInt16MultiArray,ColorRGBA,UInt64MultiArray,Int8MultiArray,Char,Int64Mult iArray,Header,String,Empty,Exporting geometry_msgs

Messages: Vector3,TwistWithCovarianceStamped,Quaternion,Pose,PolygonStamped,TransformS tamped,Twist,WrenchStamped,QuaternionStamped,PointStamped,Vector3Stamped,Point,P oseWithCovarianceStamped,Wrench,PoseArray,PoseWithCovariance,Pose2D,Point32,Tran sform,TwistWithCovariance,TwistStamped,PoseStamped,Polygon,Exporting std_srvs

Services: Empty,

Exporting sensor_msgs

Messages: ChannelFloat32,NavSatStatus,Joy,LaserScan,MagneticField,RegionOfInterest,Nav SatFix,RelativeHumidity,TimeReference,CameraInfo,MultiEchoLaserScan,JointState,P ointCloud,Range,LaserEcho,JoyFeedbackArray,JoyFeedback,PointField,Temperature,Il luminance,FluidPressure,CompressedImage,Image,Imu,PointCloud2,

Services: SetCameraInfo,

Exporting actionlib_msgs

Messages: GoalStatus,GoalID,GoalStatusArray,Exporting bond

Messages: Status,Constants,Exporting rosgraph_msgs

Messages: Log,Clock,Exporting diagnostic_msgs

Messages: DiagnosticStatus,KeyValue,DiagnosticArray,

Services: SelfTest,

Exporting roscpp

Messages: Logger,

Services: SetLoggerLevel,GetLoggers,Empty,

Exporting turtlesim

Messages: Pose,Velocity,Color,

Services: TeleportAbsolute,TeleportRelative,Spawn,Kill,SetPen,

Exporting roscpp_tutorials

Services: TwoInts,

Exporting rospy_tutorials

Messages: HeaderString,Floats,

Services: AddTwoInts,BadTwoInts,

Exporting actionlib

Messages: TestAction,TwoIntsAction,TestActionFeedback,TestActionGoal,TestFeedback,Test RequestFeedback,TestRequestActionFeedback,TestRequestActionResult,TwoIntsFeedbac k,TwoIntsActionGoal,TestRequestResult,TwoIntsGoal,TestRequestGoal,TestActionResu lt,TwoIntsResult,TestGoal,TwoIntsActionResult,TestRequestAction,TestRequestActio nGoal,TwoIntsActionFeedback,TestResult,Exporting topic_tools

Services: MuxAdd,MuxDelete,MuxList,MuxSelect,

Exporting dynamic_reconfigure

Messages: Config,DoubleParameter,ConfigDescription,Group,StrParameter,IntParameter,Par amDescription,BoolParameter,GroupState,SensorLevels,

Services: Reconfigure,

Exporting nodelet

Services: NodeletList,NodeletLoad,NodeletUnload,

Exporting beginner_tutorials

Messages: Num,

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-12-15 15:31:55 -0500

Seen: 833 times

Last updated: Jan 13 '14