Ask Your Question
0

Troubleshooting Brown's NAO Driver

asked 2011-08-22 01:00:26 -0600

Nick Armstrong-Crews gravatar image

updated 2011-08-22 09:55:32 -0600

mjcarroll gravatar image

Hi, I can't seem to get the Brown University Nao driver to work. I'm using the new Nao h25 model, with NaoQi SDK version 1.10.

When I run (locally on the robot) ./eyes, I am told "Could not get shared memory" (same issue as on [http://code.google.com/p/brown-ros-pkg/issues/detail?id=7]). When I run control.py, I get SOAP errors of the form "setVolume not a member of tts" and "setStiffness not a member of motion" ...

edit retag flag offensive close merge delete

Comments

Update: was able to get nodes to run such that I can see the /eyes topic, although it is never published to. I had to add a symlink from /opt/naoqi/modules/lib to /opt/naoqi/lib, which fixed error for eyes node; and I had to comment out setVolume, setStiffness commands in control.py
Nick Armstrong-Crews gravatar imageNick Armstrong-Crews ( 2011-08-22 01:04:18 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-08-31 03:04:33 -0600

Nick Armstrong-Crews gravatar image

Got camera feed over ROS working! But not using Brown's driver. For details, see last comment for ticket http://answers.ros.org/question/1864/nao-teleop-and-camera-feed?answer=3277

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-08-22 01:00:26 -0600

Seen: 117 times

Last updated: Aug 31 '11