ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

nao teleop and camera feed

asked 2011-08-15 01:22:11 -0500

Nick Armstrong-Crews gravatar image

updated 2011-08-15 03:10:03 -0500

AHornung gravatar image

Hi, I can't seem to get the Brown University Nao driver to work, nor the alufr (Freiburg) teleop package to work. I'm using the new Nao h25 model, with NaoQi library included in the linux Choregraphe download (I believe it is version 1.10)

[alufr] What I am able to get is odometry and joint information, via running nao_ctrl/ remotely. When I run nao_ctrl/, the robot will respond to "stand up" and "joystick control enabled" buttons, but won't actually walk. I'm using a PS3 joystick, and I checked /joy topic and indeed the walk axes (specified in ps3joystick.yaml) are getting published.

[brown] When I run (locally on the robot) ./eyes, I am told "Could not get shared memory" (same issue as on []). When I run, I get SOAP errors of the form "setVolume not a member of tts" and "setStiffness not a member of motion" ...

Thanks for any assistance!

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted

answered 2011-08-17 01:07:22 -0500

Nick Armstrong-Crews gravatar image

OK, got alufr joystick walking to work! I may not have been hitting the right button sequence; it seems the requirement is: 1) EnableControl button (robot speaks aloud "joystick control enabled") 2) InitPose button (robot stands up) 3) Walk around with joystick axes

I also may have been pointing to the wrong version of naoqi-sdk.

I am still having issues cross-compiling ROS for the nao... but I'll open a distinct ticket for that.


edit flag offensive delete link more

answered 2011-08-15 03:18:35 -0500

AHornung gravatar image

I believe brown's camera driver comes precompiled for a specific disk image / NaoQI version. If it doesn't exactly match your version it won't work.

For walking, maybe the axis mapping is different on a ps3 joystick. I am usually using a Logitech Cordless Rumblepad. Are you starting the ps3controller.launch file from the nao_remote package? That's the one translating joystick axes into walking commands.

Can you try to rostopic echo /cmd_vel and hit a few axes on your gamepad? That is the topic which is sent to the Nao as walking velocity. Otherwise Daniel could maybe tell you more, as he's also using a ps3 gamepad with Nao.

edit flag offensive delete link more

answered 2011-08-15 03:18:38 -0500

daniel_maier gravatar image


For alufr: did you try 'roslaunch nao_remote ps3controller.launch' prior to running teleop_nao_joy? This sets the mapping for the ps3 controller's buttons/axis used in teleop_nao_joy.

edit flag offensive delete link more

answered 2011-08-28 10:23:37 -0500

updated 2011-08-29 02:22:49 -0500

Hi, just a side note:

I have tried Brown's ./eyes too but it never worked for me. It's probably because that driver belongs to Nao's red version and of course Aldebaran made some changes / upgrades since then.

Also, I don't think Brown will release a new driver because the person who wrote the eyes is not at Brown anymore. However at AAAI 2011 Natanel Dukan from Aldebaran was talking about full ROS support sometime in the foreseeable future (although Aldebaran people have been saying that for almost a year now).

edit flag offensive delete link more


Just a clarification: "Them" in your last sentence probably refers to Aldebaran - and it's probably also related to the announcement of opensourcing NaoQI as well (which was announced at ICRA this year)?
AHornung gravatar image AHornung  ( 2011-08-28 19:23:12 -0500 )edit
Oops. Fixed that. Yes, <them = "Aldebaran"/>
bener suay gravatar image bener suay  ( 2011-08-29 02:23:51 -0500 )edit
Indeed, wish I had the source so I could re-(cross)-compile. I may have found a different camera bridge: , referenced at the end of this thread: . I will test it out ASAP and post results.
Nick Armstrong-Crews gravatar image Nick Armstrong-Crews  ( 2011-08-30 02:07:15 -0500 )edit
OMG, it works! I have Nao camera feed (uncompressed) visible remotely on a ROS topic. Cross-compilation of dependencies (image_transport, etc.) was a pain. I'll post instructions and/or release binaries soon as I get a chance (or send me an email)
Nick Armstrong-Crews gravatar image Nick Armstrong-Crews  ( 2011-08-31 03:02:39 -0500 )edit

Question Tools


Asked: 2011-08-15 01:22:11 -0500

Seen: 1,104 times

Last updated: Aug 29 '11