Ask Your Question
0

error while loading shared libraries - wrong ELF class

asked 2011-07-22 03:44:31 -0500

rohan_k gravatar image

updated 2014-01-28 17:10:05 -0500

ngrennan gravatar image

Hi,

I was running the tabletop_object_detector and despite always previously working, a new error has arisen (potentially as a result of "rosmake"ing some files?):

/code/shared/sr-ros-interface/public_safety/shadow_robot/tabletop_object_detector/bin/tabletop_complete_node: error while loading shared libraries: libpcl_ros_io.so: wrong ELF class: ELFCLASS64 [tabletop_complete_node-3] process has died [pid 22274, exit code 127]. log files: /home/ros/.ros/log/07310876-b471-11e0-912d-00252274d18f/tabletop_complete_node-3*.log

A google search leads me to believe it's an issue with the fact that it is a 64-bit library when it should be a 32-bit one - any ideas how to fix that? the error is only with "libpcl_ros_io"

Thanks for the help in advance as ever!

edit retag flag offensive close merge delete

Comments

Do you have a 32 or 64bit system and what is your other ROS code build on.
dornhege gravatar image dornhege  ( 2011-07-22 06:14:05 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-09-02 11:05:06 -0500

kwc gravatar image

no activity in > 1 month, closing

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-07-22 03:44:31 -0500

Seen: 431 times

Last updated: Sep 02 '11