Ask Your Question
0

Asus Xtion Not enough bandwidth

asked 2013-11-30 10:35:03 -0500

atp gravatar image

updated 2014-01-28 17:18:41 -0500

ngrennan gravatar image

I'm trying to use the Asus Xtion Pro camera with openni on Ubuntu 12.04. It does not work. Running dmesg in the terminal gives:

[15844.380294] usb 3-9: new high-speed USB device number 13 using xhci_hcd
[15844.400319] usb 3-9: New USB device found, idVendor=1d27, idProduct=0600
[15844.400327] usb 3-9: New USB device strings: Mfr=2, Product=1, SerialNumber=0
[15844.400333] usb 3-9: Product: PrimeSense Device
[15844.400337] usb 3-9: Manufacturer: PrimeSense
[15844.401720] usb 3-9: Not enough bandwidth for new device state.
[15844.401738] usb 3-9: can't set config #1, error -28

I've tried all the USB ports on the computer. It always gives the same error.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2013-12-03 06:17:31 -0500

atp gravatar image

updated 2013-12-03 06:17:47 -0500

I've solved this problem by deactivating xHCI and EHCI Hand-off in the bios of the motherboard.

edit flag offensive delete link more

Comments

Yup, that seems like a good solution. The Xtion and Kinect don't work on USB 3.0 (xhci) ports. If you're lucky, your PC has at least one USB 2.0 (ehci) port; otherwise, you have to disable xhci (either in the bios, or by blacklisting the kernel module).

Martin Günther gravatar image Martin Günther  ( 2013-12-04 21:24:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-11-30 10:35:03 -0500

Seen: 7,358 times

Last updated: Dec 03 '13