Ask Your Question
3

Help with Installing packages and repositories

asked 2011-06-28 18:18:53 -0500

xalu gravatar image

updated 2011-09-28 04:18:52 -0500

joq gravatar image

I am trying to install a few different packages but am at a loss on getting them to work.

For example, I am trying to install usb_cam and getting this error mkdir: cannot create directory `build': Permission denied

Also, when there is a repository how do I add it? I keep trying to find it in the documentation but if someone wouldn't mind giving me an example.

mary_tts or usb_cam would be a good working example for me to go by if someone doesn't mind helping.

Thanks!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
9

answered 2011-06-28 21:22:36 -0500

Lorenz gravatar image

updated 2011-06-29 04:36:34 -0500

Generally you should not install packages by hand in system directories such as /opt/ros/diamondback. People normally create an overlay in their home directory. An easy way of creating such an overlay (and installing stacks/packages) is by using rosinstall. To create an overlay in ~/ros, you can do the following:

rosinstall ~/ros /opt/ros/diamondback

Then replace the line

source /opt/ros/diamondback/setup.bash

in your ~/.bashrc with the line

source ~/ros/setup.bash

Now, if you want to install a new stack that is not available as a debian package (e.g. bosch_drivers which contains usb_cam), execute the following:

roslocate info bosch_drivers > ~/bosh_drivers.rosinstall
rosinstall ~/ros ~/bosh_drivers.rosinstall

After opening a new terminal to reload setup.bash you will have the package usb_cam in your package path and you should be able to rosmake it.

edit flag offensive delete link more

Comments

Thanks! Okay. I tried rosinstall and roslocate, but both are command not found. I looked them up and they should be installed when I set up ROS?
xalu gravatar imagexalu ( 2011-06-29 06:05:27 -0500 )edit
You can find install instructions here: http://www.ros.org/wiki/rosinstall
Lorenz gravatar imageLorenz ( 2011-06-29 07:36:29 -0500 )edit
Thanks Lorenz! :) I had time to set this up and just used this, wow does that make everything work :). Why isn't this page one of the tutorial? Thanks again. Really makes everything much easier.
xalu gravatar imagexalu ( 2011-06-29 12:50:40 -0500 )edit
0

answered 2011-06-28 19:59:04 -0500

xalu gravatar image

updated 2011-06-28 20:12:54 -0500

Well it seems I was just having a permission problem and I should have realized how to fix it. I tried changing the folder to 775 before but the trick in here helped. http://roslauragalindez.blogspot.com/2011/01/usbcam-and-rviz-compilation.html

This tutorial about building stacks should be on the main tutorial page. It was very hard to find. Anyone trying to find the how to install a stack from scratch or through SVN should check this out --> http://www.ros.org/wiki/ROS/Tutorials/StackInstallation

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

4 followers

Stats

Asked: 2011-06-28 18:18:53 -0500

Seen: 5,842 times

Last updated: Jun 29 '11