Ask Your Question
3

Stereovslam error :: Assertion `left_.tfFrame() == right_.tfFrame()'

asked 2011-06-23 05:35:25 -0600

rajat gravatar image

updated 2011-06-23 05:36:37 -0600

After i publish my two left and right videos from stereo camera and run stereo_synchronizer node and stereo_image_proc node everything seems to go file but i get this error from stereo_vslam_node and see no output:

stereo_vslam_node: /opt/ros/diamondback/stacks/vision_opencv/image_geometry/src/stereo_camera_model.cpp:28: bool image_geometry::StereoCameraModel::fromCameraInfo(const sensor_msgs::CameraInfo&, const sensor_msgs::CameraInfo&): Assertion `left_.tfFrame() == right_.tfFrame()' failed.

image description You can zoom in the file by opening it in another window. Here is how my system looks , does anybody has anyidea what might be going wrong ??

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2011-08-19 08:43:24 -0600

the frame on each camera should be the same. You're likely using separate frames for each, which might make intuitive sense, but the transforms re camerainfo are all meant to be referencing the same frame, and so stereo_image_proc needs them to be the same.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-06-23 05:35:25 -0600

Seen: 581 times

Last updated: Aug 19 '11