Ask Your Question
0

vlsam rviz error

asked 2011-08-31 01:16:23 -0600

GuoliangLiu gravatar image

The command "rosrun rviz rviz -d --sync simple_vslam.vcg" worked very well before I upgrade my Ubuntu system. Now it just shows the errors:

The program 'rviz' received an X Window System error. This probably reflects a bug in the program. The error was 'BadWindow (invalid Window parameter)'. (Details: serial 29 error_code 3 request_code 138 minor_code 4) (Note to programmers: normally, X errors are reported asynchronously; that is, you will receive the error a while after causing it. To debug your program, run it with the --sync command line option to change this behavior. You can then get a meaningful backtrace from your debugger if you break on the gdk_x_error() function.)

Anyone has the same problem? My system right now is Ubuntu natty 11.04

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2011-09-02 11:06:57 -0600

Helen gravatar image

vslam is unsupported experimental research code. It is not actively being supported, but patches are welcome.

However, this appears to be a problem with rviz rather than with vslam. Instead of loading the vcg, try adding the pose markers and points to rviz manually.

edit flag offensive delete link more
0

answered 2011-09-29 00:19:00 -0600

Scott gravatar image

I have had this problem so many times it is not even funny. It is my biggest complaint about rviz. What's happening is the last time you ran rviz with some configuration, it remembers it. And that can cause problems if you try to load it later for lots of reasons. Best way around this is to load an empty.vcg file. THEN do the step above where you manually load whatever you want or afterwards go load some new vcg file. The visualization stack has a nice one that worked for me. You can find it at /opt/ros/electric/stacks/visualization/rviz/test/old_configs Then run rosrun rviz rviz -d ./empty.vcg

Good luck. Hope this helped. -Scott

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-08-31 01:16:23 -0600

Seen: 186 times

Last updated: Sep 29 '11