Ask Your Question
1

Build pcl_conversions on PandaBoard

asked 2013-11-20 04:35:12 -0500

RodBelaFarin gravatar image

updated 2014-01-28 17:18:36 -0500

ngrennan gravatar image

I tried to install the navigation stack on PandaBoard. First i tried with sudo apt-get install ros-hydro-navigation, then everything seems to work fine, but when starting for example the move_base package by running "roslaunch navigation move_base.launch", errors occurred:

ERROR: cannot launch node of type [map_server/map_server]: can't locate node [map_server] in package [map_server]

ERROR: cannot launch node of type [move_base/move_base]: can't locate node [move_base] in package [move_base]

and so on.

so I tried to build the navigation stack from source. I downloaded from github in my catkin workspace and tried to compile with "catkin_make". After a while it is running in the package "costmap2d", which ends up with errors again:

Could not find a package configuration file provided by "pcl_conversions" with any of the following names:

pcl_conversionsConfig.cmake
pcl_conversions-config.cmake

Add the installation prefix of "pcl_conversions" to CMAKE_PREFIX_PATH or set "pcl_conversions_DIR" to a directory containing one of the above files. If "pcl_conversions" provides a separate development package or SDK, be sure it has been installed. Call Stack (most recent call first): navigation/costmap_2d/CMakeLists.txt:4 (find_package)

It seems for me that pcl_conversions is not installed in the right way. I looked for the files in /opt/ros/hydro/shared/pcl_conversions/cmake/ and they exist!

So i tried installing pcl_conversions first by sudo apt-get install ros-hydro-pcl-conversion (which works fine again) and after getting the same error I tried to build it from source. I downloaded pcl_conversions from github, created a build directory and runed cmake .. and make out of it, but make does not seem to do anything. so I am not sure if it is really installed in the right way.

Have no clue, hope for any idea.

edit retag flag offensive close merge delete

Comments

Can you tell me how you solved the problem. I have a similar one.

BenediktHeck gravatar image BenediktHeck  ( 2014-05-15 06:49:17 -0500 )edit

could you be a bit more precise?if you are using PandaBoard I would really, REALLY recommend to use Ubuntu 12.04 with ROS Hydro.After my experience with ARM hardware, this is the best configuration. There binary install of navigation should work and compilinig from source via catkin also. Good luck!

RodBelaFarin gravatar image RodBelaFarin  ( 2014-05-15 09:54:55 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-12-09 21:42:24 -0500

ahendrix gravatar image

Have you tried installing the ros-hydro-map-server and ros-hydro-move-base packages? Those were working for me.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-11-20 04:35:12 -0500

Seen: 1,205 times

Last updated: Dec 09 '13