ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

libuvc_camera - Camera Doesn't Respond To Parameter Changes

asked 2013-11-11 15:13:01 -0600

trianta2 gravatar image

updated 2013-11-14 10:39:04 -0600

tfoote gravatar image

Hi Everyone,

I have a Logitech C920 that I'm using with the libuvc_camera node. I've followed the instructions here: My goal is to disable auto focus and auto exposure and set them manually.

I can view the image stream (using the image_view node), so I know the camera works. I tried to disable auto focus/auto exposure via the libuvc_camera service, however the camera continued to to set the focus and exposure automatically. I tried to set other parameters such absolute exposure and focus, however the camera did not respond to these changes.

I confirmed that my desired parameter values were set by printing the current node configuration to console.

Does anyone have any idea why the camera isn't responding to these parameter changes? Do I need to run the libuvc_camera node as a super user or something?

Thank you for any insight.

edit retag flag offensive close merge delete



I had the same issue with the same camera. As far as I remember the problem was caused by not having write permissions to /dev/bus/usb. I don't think you need root permissions. Check the write permissions just like it's recommend here

Artem gravatar image Artem  ( 2013-11-13 05:16:22 -0600 )edit

I followed the instructions in that link, specifically I set " #UVC cameras SUBSYSTEMS=="usb", ATTRS{idVendor}=="046d", MODE="0666" " in my 99-uvc.rules file. I found that I was able to disable auto exposure, but I cannot manually set exposure time, the aperture, or disable auto focus. Could you?

trianta2 gravatar image trianta2  ( 2013-11-13 07:17:52 -0600 )edit

Were you able to control the iris or exposure manually?

trianta2 gravatar image trianta2  ( 2013-11-13 08:43:24 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2013-11-11 19:42:58 -0600

tfoote gravatar image

It's possible there's a permissions level issue. It's also possible that the camera simply does not support changing those modes.

There's a lot of the cheaper web cameras that simply don't implement the full specifications for the interface.

edit flag offensive delete link more


Hi, thank you for your answer. We were actually able to control focus/exposure on this exact camera using libuvc in an OpenCV implementation. I don't see why ROS would be having this issue. I will try running libuvc_camera as a super user.

trianta2 gravatar image trianta2  ( 2013-11-12 00:31:30 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2013-11-11 15:13:01 -0600

Seen: 5,974 times

Last updated: Nov 13 '13