Ask Your Question
1

Turtlebot2 does not move in Gazebo

asked 2013-11-09 17:41:12 -0500

Robocop87 gravatar image

updated 2013-11-10 14:33:40 -0500

Hi all!

So according to this tutorial: http://wiki.ros.org/turtlebot_simulator/Tutorials/hydro/Explore%20the%20Gazebo%20world

All I need to do to tele-op the turtlebot2 in gazebo is:

roslaunch turtlebot_gazebo turtlebot_empty_world.launch
roslaunch turtlebot_teleop keyboard_teleop.launch

However when I do this, the turtlebot does not move. I have also tried running:

roslaunch turtlebot_bringup minimal.launch

and creating a python node to move it, all to no avail. What am I missing?

Thank you to bit-pirate for catching my missing specs: Ubuntu 12.04, ROS Hydro, i used sudo apt-get install ros-hydro-turtlebot* to get the packages.

EDIT: My Turtlebot2 simulation IS MOVING, however it is moving so slow that you can't even see it move unless you leave Gazebo running for a while and come back to it. How can I make Gazebo run faster?

edit retag flag offensive close merge delete

Comments

I am thinking of using turtlebot on Gazebo. As I am new to Gazebo; initially I thought that for turtlebot 2D navigation stack is already set up and we can control everything from rviz. Does we need to write code for moving the turtlebot? Do you know any robot in Gazebo-Ros for which 2D navigation stack is already tuned properly?

RB gravatar image RB  ( 2013-11-09 18:26:27 -0500 )edit

Hi Brian, the navigation stack does already have a lot of utilities for using the turtlebot, the only one I know of that uses rviz though is the goal waypoints you can set while using amcl. I am writing code to move it simply because my application requires it.

Robocop87 gravatar image Robocop87  ( 2013-11-09 18:45:06 -0500 )edit
1

Hi, my requirement is also similar to you, but right now I need a robot upon which 2D navigation stack properly set up. I am planning to incorporate my own code inside amcl. As you have said for TurtleBot, we can use 2D nav stack; does this robot can be properly launched in Gazeb? Does turtleBot can avail all the functionality of 2D nav stack.? Thanks 4 ur reply.

RB gravatar image RB  ( 2013-11-09 19:55:13 -0500 )edit
1

@Robocop87 The instructions on the wiki work out of the box for me - no need to create nor run extra nodes. Please specific more details about your setup (what and how did you install the turtlebot packages, what versions are you using (Ubuntu, ROS, turtlebot packages)).

bit-pirate gravatar image bit-pirate  ( 2013-11-10 12:46:37 -0500 )edit

Added the specs, thanks for the catch. Still doesn't work for me though =/

Robocop87 gravatar image Robocop87  ( 2013-11-10 13:19:30 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-11-10 14:59:27 -0500

bit-pirate gravatar image

First of all you should __not__ use turtlebot_bringup minimal.launch. That launcher is for running the real robot. The Gazebo plugins for TurtleBot are basically reproducing the same functionalities (not everything is implemented though).

What does Gazebo's real time factor say? Maybe the simulation is running really slowly on your machine (my "Real Time Factor" is at 1.0).

Note that turtlebot_teleop's keyboard_teleop requires you to keep the buttons pressed. Please also try roslaunch kobuki_keyop keyop.launch.

edit flag offensive delete link more

Comments

Thanks for your answer bit-pirate, I have since stopped attempting to run turtlebot_bringup as I realized it was causing nodes to crash in Gazebo. My real time factor says 1.0

Robocop87 gravatar image Robocop87  ( 2013-11-10 15:25:28 -0500 )edit

Odd... Please add the version numbers of Gazebo and the turtlebot, turtlebot_apps, turtlebot_simulator, kobuki and kobuki_desktop packages to your question.

bit-pirate gravatar image bit-pirate  ( 2013-11-10 15:35:55 -0500 )edit

Gazebo: 2.0.0 Turtlebot: 2.2.2 Turtlebot_apps: 2.2.4 Turtlebot_simulator: 2.1.1 Kobuki: 0.5.5 Kobuki_desktop: 0.3.1

Robocop87 gravatar image Robocop87  ( 2013-11-10 17:21:04 -0500 )edit
2

Gazebo 2.0! That might be it. I tested version 2.0 after the release and ran into some problems. So far no one got around implementing the necessary changes. Please revert back to Gazebo 1.9.1. and do try teleop again.

bit-pirate gravatar image bit-pirate  ( 2013-11-10 18:15:31 -0500 )edit

Could this possibly have any connection with my graphics card? I imagine it moving too slow could mean its not good enough?

Robocop87 gravatar image Robocop87  ( 2013-11-15 16:22:50 -0500 )edit

If your real time factor is at 1.0, it should be fine. If the simulation time would pass much slower than real time, then there would probably be too much load on your system. Did you test the turtlebot simulation with Gazebo 1.9?

bit-pirate gravatar image bit-pirate  ( 2013-11-17 18:38:20 -0500 )edit

No I never did, I never figured out how to revert the version and I ended up just using another computer...sorry!

Robocop87 gravatar image Robocop87  ( 2013-12-07 17:39:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-11-09 17:41:12 -0500

Seen: 2,274 times

Last updated: Nov 10 '13