Ask Your Question
0

set a goal in the inflated obstacles area

asked 2011-04-22 21:10:29 -0600

Charles gravatar image

From my understanding, if we set a navigation goal in inflated obstacles, the navigation stack won't give a path plan. So, how can I configure the stack to let the it give a path plan, which navigate the robot to a position near the goal?

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
1

answered 2011-04-25 05:20:03 -0600

eitan gravatar image

The navigation stack will not plan a path to a goal given in an inflated obstacle because a cell marked as such guarantees that any concave robot footprint would be in collision if the center-point of that footprint were placed at that cell. Basically, if the navigation stack were to attempt to achieve such a goal, it would hit something.

If you want the navigation stack to get as close to this goal as possible, you might want to check out the "default_tolerance" parameter that can be set on navfn documented here: http://www.ros.org/wiki/navfn#Parameters. Setting that parameter should allow you to specify goals inside of inflated obstacles where the robot will try to get close.

edit flag offensive delete link more

Comments

However seems this value is not used where it's supposed to use.

bool GlobalPlanner::makePlan(const PoseStamped& start, const PoseStamped& goal, double tolerance, std::vector<posestamped>& plan)

https://github.com/ros-planning/navig...

AravindaDP gravatar imageAravindaDP ( 2016-12-07 07:30:31 -0600 )edit

Furthermore it is reported but not resolved yet.

https://github.com/ros-planning/navig...

AravindaDP gravatar imageAravindaDP ( 2016-12-07 07:33:21 -0600 )edit
0

answered 2011-04-24 16:41:46 -0600

Charles gravatar image

In my rviz, both of the fixed frame and target frame are '/map'. Following is my common costmap configuration:


map_type: costmap
transform_tolerance: 0.2
obstacle_range: 2.5
raytrace_range: 3.0
inflation_radius: 0.55
footprint: [[0.13, 0.35],
            [0.25, 0.15],
            [0.25, -0.15],
            [0.13, -0.35],
            [-0.13, -0.35],
            [-0.25, -0.15],
            [-0.25, 0.15],
            [-0.13, 0.35]]

observation_sources: base_scan

base_scan: {data_type: LaserScan,
            topic: /base_scan,
            expected_update_rate: 0.4,
            observation_persistence: 0.0,
            marking: true,
            clearing: true,
            min_obstacle_height: 0.08,
            max_obstacle_height: 2.0}

global_costmap:

global_costmap:
    publish_voxel_map: true
    global_frame: /map
    robot_base_frame: base_link
    update_frequency: 5.0
    publish_frequency: 0.0
    static_map: true
    rolling_window: false

local_costmap:

 
local_costmap:
    publish_voxel_map: true
    global_frame: odom
    robot_base_frame: base_link
    update_frequency: 5.0
    publish_frequency: 2.0
    static_map: false
    rolling_window: true
    width: 10.0
    height: 10.0
    resolution: 0.025
    origin_x: 0.0
    origin_y: 0.0

edit flag offensive delete link more
0

answered 2011-04-24 21:30:53 -0600

Charles gravatar image

perhaps carrot_planner can solve this problem.

edit flag offensive delete link more
0

answered 2011-04-23 01:51:17 -0600

Charles gravatar image

Yes, I have tried it by using navigation stage. When I set a goal in the inflated obstacles, the navigation stack didn't give a plan, and the robot began to rotate. After that, the stack threw an error.

[ERROR] [1303565646.145455982, 30.900000000]: Aborting because a valid plan could
 not be found. Even after executing all recovery behaviors
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-04-22 21:10:29 -0600

Seen: 842 times

Last updated: Apr 25 '11