Ask Your Question
1

trying to install ROS from source on UBUNTU 13.10

asked 2013-11-05 06:10:10 -0500

ltorabi gravatar image

updated 2016-03-22 06:00:31 -0500

gvdhoorn gravatar image

Hi

I am trying to install ROS from source on UBUNTU 13.10, and gets stock on the qt_qui_cpp package and gives this error:

==> Processing catkin package: 'qt_gui_cpp'
==> Building with env: '/home/ltorabi/ros_catkin_ws/install_isolated/env.sh'
Makefile exists, skipping explicit cmake invocation...
==> make cmake_check_build_system in '/home/ltorabi/ros_catkin_ws/build_isolated/qt_gui_cpp'
==> make -j2 -l2 in '/home/ltorabi/ros_catkin_ws/build_isolated/qt_gui_cpp'
[ 76%] Built target qt_gui_cpp
[ 84%] Running SIP generator for qt_gui_cpp_sip Python bindings...
sip: Deprecation warning: qt_gui_cpp.sip:1: %Module version number should be specified using the 'version' argument
sip: Unable to find file "QtCore/QtCoremod.sip"
Error: Unable to open
"/ros_catkin_ws/build_isolated/qt_gui_cpp/sip/qt_gui_cpp_sip/pyqtscripting.sbf"
make[2]: *** [sip/qt_gui_cpp_sip/Makefile] Error 1
make[1]: *** [src/qt_gui_cpp_sip/CMakeFiles/libqt_gui_cpp_sip.dir/all] Error 2
make: *** [all] Error 2
<== Failed to process package 'qt_gui_cpp':
edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2016-03-22 05:46:54 -0500

updated 2016-03-22 06:08:51 -0500

This error may also happen if you are trying to build ROS with jade inUubuntu 15.10 (or other version of ROS or ubuntu).

It is solved if you install a few packages:

$ sudo apt-get install sip-dev python-qt4-dev python-sip-dev pyqt4-dev-tools

edit flag offensive delete link more

Comments

This fixed it for us in Ubuntu 17.04, but nowadays the packages to install are a little different:

sudo apt-get install sip-dev pyqt5-dev python-sip-dev pyqt5-dev-tools
paol gravatar image paol  ( 2017-10-18 05:10:53 -0500 )edit
1

answered 2013-11-05 06:13:38 -0500

teddybouch gravatar image

It looks to me like your qt libraries either aren't installed or aren't up-to-date. I would try doing that and then attempting installation again.

edit flag offensive delete link more

Comments

Thanks for the quick answer, but I got the updated qt_gui_cpp from the repository : Source: git https://github.com/ros-visualization/qt_gui_core (branch: groovy-devel) and still doesn't work

ltorabi gravatar image ltorabi  ( 2013-11-05 06:19:55 -0500 )edit

Check your system dependencies not your ROS dependencies.

tfoote gravatar image tfoote  ( 2013-11-05 09:41:14 -0500 )edit

Thanks a lot. I got passed that by installing PYQT4, but then gives me the following error even though I used configure.py and not configure-ng.py for installing Pyqt4: [ 84%] Running SIP generator for qt_gui_cpp_sip Python bindings... File "/ros_catkin_ws/install_isolated/share/python_qt_binding/cmake/sip_configure.py", line 3, in <module> from PyQt4 import pyqtconfig ImportError: cannot import name pyqtconfig So I am not sure what is the "pyqtconfig" !! Is it a module or a .py file, and where should be located. Because as I see the pyqtconfig.py is configured and located in the "PyQt-x11-gpl-4.10.3" folder not in the "/usr/share/sip/PyQt4" folder

ltorabi gravatar image ltorabi  ( 2013-11-06 06:12:25 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-11-05 06:10:10 -0500

Seen: 2,004 times

Last updated: Mar 22 '16