Ask Your Question
1

ROS rviz OGRE EXCEPTION

asked 2013-10-28 14:03:47 -0500

Operating System Details: Ubuntu 12.04 LTS (Precise Pangolin) - ROS Hydro

The following command:

rosrun rviz rviz

Briefly displays the rviz logo, before repeating the following error 100 times:

[ WARN] [1383004708.902971662]: OGRE EXCEPTION(3:RenderingAPIException): Invalid parentWindowHandle (wrong server or screen) in GLXWindow::create at /build/buildd/ogre-1.7.4/RenderSystems/GL/src/GLX/OgreGLXWindow.cpp (line 229)

rviz::RenderSystem: error creating render window: std::exception

And then finally giving up with the following messages:

[ERROR] [1383004708.903200106]: Unable to create the rendering window after 100 tries.

rviz: /tmp/buildd/ros-hydro-rviz-1.10.9-0precise-20131021-0017/src/rviz/ogre_helpers/render_system.cpp:374: Ogre::RenderWindow* rviz::RenderSystem::makeRenderWindow(intptr_t, unsigned int, unsigned int): Assertion `false' failed.

Aborted (core dumped)

I've tried re-installing rviz, which didn't help. Also, I was having the same problem before moving from fuerte to hydro (though a long while back rviz was working fine with fuerte). I suspect it has been an update to rviz or ogre which has caused this problem, but I'm not really sure how to go about attempting to repair it..

edit retag flag offensive close merge delete

Comments

1

Try 'sudo apt-get install --reinstall nvidia-current'

dgossow gravatar imagedgossow ( 2013-10-29 04:42:47 -0500 )edit

I have them same error and dgossow's suggestion didn't work. Any other ideas?

Tim Murphy gravatar imageTim Murphy ( 2014-04-08 07:51:17 -0500 )edit

Same problem here with 12.04 and Hydro and the following hardware: 01:00.0 3D controller: NVIDIA Corporation GK107M [GeForce GT 740M] (rev a1) Subsystem: ASUSTeK Computer Inc. Device 1587 Kernel driver in use: nvidia Kernel modules: nvidia_331_updates, nvidia_304_updates, nouveau, nvidiafb

bwillaert gravatar imagebwillaert ( 2014-07-29 04:08:14 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-10-29 02:30:20 -0500

It doesn't look like I am able to answer my own question, but I managed to get around the problem:

I changed my graphics drivers according to post #16 on the following link:

http://ubuntuforums.org/showthread.ph...

My suspicion is that there is some incompatibility between Ogre3D and the nvidia proprietry drivers, so its best to avoid them.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-10-28 14:03:47 -0500

Seen: 4,302 times

Last updated: Oct 28 '13