ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
1

PointCloud alignment

asked 2011-03-19 07:16:11 -0600

updated 2016-10-24 08:59:29 -0600

ngrennan gravatar image

I'm getting some strange behavior with pointcloud_to_laserscan where after doing some tests it appears that part of the pointcloud isn't being used to update the laser scan. Although the pointcloud is displayed correctly within Rviz I notice that within pointcloud_to_laserscan I'm getting a significant number of NaNs which are then ignored. Could this be something to do with 16 byte SSE alignment ?

edit retag flag offensive close merge delete

Comments

What is producing your PointClouds? Do the input clouds contain NaNs?
Eric Perko gravatar image Eric Perko  ( 2011-03-19 08:02:30 -0600 )edit
It's originally coming from /camera/depth/points, then going through cloud_throttle. It looks as if the throttle isn't doing much, and I can also directly feed in /camera/depth/points and get the same result.
JediHamster gravatar image JediHamster  ( 2011-03-19 08:08:51 -0600 )edit
The point cloud /camera/depth/points appears to be shown correctly within Rviz, with the points which don't make it through pointcloud_to_laserscan being displayed.
JediHamster gravatar image JediHamster  ( 2011-03-19 08:09:24 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2011-03-24 09:50:00 -0600

tfoote gravatar image

The pointcloud_to_laser scan node only takes a slice of the point cloud. Which is parameterized by min_height and max_height defaulting to 0.1 and 0.15 by default. [source]

edit flag offensive delete link more
0

answered 2011-03-24 10:04:11 -0600

This turned out to be my misunderstanding about the coordinates of the point cloud. I'd assumed that it would be in world coordinates rather than camera coordinates, so hence my tests were giving all kinds of crazy results. Transforming the coordinates to a frame at the base of the robot fixed the problem.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2011-03-19 07:16:11 -0600

Seen: 1,152 times

Last updated: Mar 24 '11