Ask Your Question
1

rosbuild error during ros install mac osx 10.6.6

asked 2011-03-16 22:48:30 -0500

paulo gravatar image

updated 2012-03-16 15:23:07 -0500

Kevin gravatar image

on a Mac OSX 10.6.6,

I had the following error for ros install command: rosinstall ~/ros "http://packages.ros.org/cgi-bin/gen_rosinstall.py?rosdistro=diamondback&variant=ros-full&overlay=no"

what went wrong? [ rosmake ] rosdep successfully installed all system dependencies
[ rosmake ] Starting >>> tools/rospack
[ rosmake ] Finished <<< tools/rospack
[rosmake-0] Starting >>> roslib [ make ]
[ rosmake ] All 20 linesoslib: 0.7 sec ] [ 1 Active 1/68 Complete ] {------------------------------------------------------------------------------- mkdir -p bin cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=rospack find rosbuild/rostoolchain.cmake .. [rosbuild] Building package roslib [rosbuild] Including /Users/paulogoncalves/ros/ros_comm/clients/roslisp/cmake/roslisp.cmake [rosbuild] Including /Users/paulogoncalves/ros/ros_comm/clients/rospy/cmake/rospy.cmake [rosbuild] Including /Users/paulogoncalves/ros/ros_comm/clients/cpp/roscpp/cmake/roscpp.cmake Traceback (most recent call last): File "/Users/paulogoncalves/ros/ros/bin/rosboost-cfg", line 35, in <module> rosboost_cfg.main() File "/Users/paulogoncalves/ros/ros/tools/rosboost_cfg/src/rosboost_cfg/rosboost_cfg.py", line 328, in main raise BoostError("Cannot find boost in any of %s"%search_paths(options.sysroot)) rosboost_cfg.rosboost_cfg.BoostError: "Cannot find boost in any of [('/usr', True), ('/usr/local', True)]" CMake Error at /Users/paulogoncalves/ros/ros/core/rosbuild/public.cmake:848 (message): rosboost-cfg --include_dirs failed Call Stack (most recent call first): CMakeLists.txt:5 (rosbuild_add_boost_directories)

-- Configuring incomplete, errors occurred! -------------------------------------------------------------------------------} [ rosmake ] Output from build of package roslib written to: [ rosmake ] /Users/paulogoncalves/.ros/rosmake/rosmake_output-20110317-103414/roslib/build_output.log [rosmake-0] Finished <<< roslib [FAIL] [ 0.78 seconds ]
[rosmake-1] Starting >>> rosemacs [ make ]
[rosmake-1] Finished <<< rosemacs No Makefile in package rosemacs
[rosmake-2] Starting >>> rosboost_cfg [ make ]
[rosmake-2] Finished <<< rosboost_cfg No Makefile in package rosboost_cfg
[ rosmake ] Halting due to failure in package roslib. [ rosmake ] Waiting for other threads to complete. [rosmake-3] Starting >>> rosbash [ make ]
[rosmake-3] Finished <<< rosbash No Makefile in package rosbash
[ rosmake ] Results:
[ rosmake ] Built 5 packages with 1 failures.
[ rosmake ] Summary output to directory
[ rosmake ] /Users/paulogoncalves/.ros/rosmake/rosmake_output-20110317-103414
Traceback (most recent call last): File "/usr/local/bin/rosinstall", line 5, in <module> pkg_resources.run_script('rosinstall==0.5.16', 'rosinstall') File "/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/pkg_resources.py", line 442, in run_script self.require(requires)[0].run_script(script_name, ns) File "/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/pkg_resources.py", line 1167, in run_script exec script_code in namespace, namespace File "/Library/Python/2.6/site-packages/rosinstall-0.5.16-py2.6.egg/EGG-INFO/scripts/rosinstall", line 556, in <module>

File "/Library/Python/2.6/site-packages/rosinstall-0.5.16-py2.6.egg/EGG-INFO/scripts/rosinstall", line 547, in rosinstall_main

File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/subprocess.py", line 462, in check_call raise CalledProcessError(retcode, cmd) subprocess.CalledProcessError: Command 'source /Users/paulogoncalves/ros/setup.sh && rosmake ros ros_comm --rosdep-install' returned non-zero exit status 1

edit retag flag offensive close merge delete

Comments

2 Answers

Sort by ยป oldest newest most voted
0

answered 2011-08-02 11:09:13 -0500

Wim gravatar image
edit flag offensive delete link more
1

answered 2011-12-15 11:47:55 -0500

zmoratto gravatar image

This problem also happened for me on 10.7 with Macports. I found the correct solution to be defining CPATH and DYLD_FALLBACK_LIBRARY_PATH. So run the follow bash script prior to running 'rosinstall'.

PORTS=/opt/local
export CPATH=$PORTS/include
export DYLD_FALLBACK_LIBRARY_PATH=$DYLD_FALLBACK_LIBRARY_PATH:$PORTS/lib
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-03-16 22:48:30 -0500

Seen: 900 times

Last updated: Dec 15 '11