Ask Your Question
2

Household_objects_database new entries

asked 2011-03-14 22:23:08 -0600

Lorenzo gravatar image

updated 2011-04-15 01:57:14 -0600

I would like to know about the possibility to add objects to the household_objects_database once it is downloaded and run on local machine. Is it possible for example using rein or other tools from the object_recognition stack?

Thank you so much

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
0

answered 2011-06-17 11:32:19 -0600

ethanrublee gravatar image

https://code.ros.org/svn/wg-ros-pkg/stacks/object_manipulation/trunk/household_objects_database/src/mesh_loader.cpp is a good starting place for this task.

Try using this as a template to move forward.

edit flag offensive delete link more
1

answered 2011-06-20 04:55:35 -0600

Matei Ciocarlie gravatar image

After upgrading to diamondback, also take a look at the insert_model.cpp node in the household_objects_database package. This allows you to add new object models (meshes) to the database. It is somewhat crude and not well parameterized, but should have all the info needed.

edit flag offensive delete link more
0

answered 2012-01-13 06:04:34 -0600

Hououin Kyouma gravatar image

Hi Lorenzo, thanks for your reply, but coincidentally I figured out my problem just today. It doesn't really matter which application you use for creating the model, but you have to make sure that the size of the model is specified in meters because that is what the household_database apparently uses. The model I created was specified in centimeters, so when I tried to load the model from the database I got the error I mentioned. Correcting this to meters solves the problem. After this I also loaded models created in 3dSMax which worked perfectly.

edit flag offensive delete link more
0

answered 2012-01-03 00:24:29 -0600

Hououin Kyouma gravatar image

Hi, I'm also trying to add objects to this database and insert_model.cpp seems to work for me, except that the code doesn't add the object into a model set, so I had to adjust the database myself. However, when I try to launch tabeltop_complete.launch I get the following error:

terminate called after throwing an instance of 'std::bad_alloc'  
what(): std::bad_alloc

I suspect that the model I made is faulty, is there a good way to create models? I used Solidworks to create the model in STL format, then used Blender to convert it to .ply. I also tried 3DSom as described in the link below, but 3DSom is licensed and doesn't work properly for me. Are there any other ways to create 3D models?

http://www.ros.org/wiki/household%20objects

edit flag offensive delete link more

Comments

Hi! We used 3dSmax to create the models in obj format, then we converted them in .ply format with the meshlab software. We also modified the insert_model.cpp code, but I don't remember exactly how...Try creating models as we did, as soon as I can I'll tell you how to modify the code, too.
Lorenzo gravatar imageLorenzo ( 2012-01-12 19:30:53 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-03-14 22:23:08 -0600

Seen: 674 times

Last updated: Jan 13 '12