Ask Your Question
0

Failed to setup the capture workspace for object_recognition

asked 2012-08-22 22:26:09 -0500

updated 2012-09-05 23:06:58 -0500

Hi, I am following [quick guide of recognition kitchen].(http://ecto.willowgarage.com/recognition/ros_quickguide.html)

But when I run this code in my third terminal:

  rosrun object_recognition_core orb_template.py -o my_textured_plane

I got this message in terminal:

  Traceback (most recent call last):
    File "./orb_template.py", line 3, in <module>
      from object_recognition_capture.orb_capture import *
  ImportError: No module named object_recognition_capture.orb_capture

Does anybody know how to get this module(object_recognition_capture.orb_capture)? I am using electric on Ubuntu 10.10.

Thanks in advance.

Edit

After I:

  sudo apt-get install ros-electric-object-recognition

The error message became:

  Listening for key: s on imshow:save
  Registration? 1
  Sync? 0
  Traceback (most recent call last):
    File       "/opt/ros/electric/stacks/object_recognition/object_recognition_core/bin/orb_template.py", line 95, in <module>
run_plasm(options, plasm, locals=vars())
    File "/opt/ros/electric/stacks/object_recognition/object_recognition_core/pyshared/ecto/opts.py", line 90, in run_plasm
sched.execute(options.niter, options.nthreads)
  ecto.CellException:            exception_type  CellException
                  cell_name  Source
                  cell_type  ecto::py::BlackBox
              function_name  process
                       type  std::runtime_error
                       what             exception_type  CellException
                  cell_name  ecto_openni::OpenNICapture
                  cell_type  ecto_openni::OpenNICapture
              function_name  configure
                       type  std::runtime_error
                       what  Index out of range.0 devices found.
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2012-08-22 23:13:44 -0500

Did you install object_recognition from source or as a deb package? I just tested with...

sudo apt-get install ros-electric-object-recognition

... and it worked (at least I got past the point where you got that error). Make sure you don't have another copy of object_recognition checked out somewhere on your ROS_PACKAGE_PATH.

edit flag offensive delete link more

Comments

I followed your installation method and the error came different.I'll try other way.Thank you!

Po-Jen Lai gravatar image Po-Jen Lai  ( 2012-09-05 23:02:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-08-22 22:26:09 -0500

Seen: 420 times

Last updated: Sep 05 '12