Ask Your Question
0

Error while using cmake install for sphero_ros

asked 2013-09-24 08:00:47 -0500

shahensha gravatar image

updated 2013-11-18 16:52:49 -0500

tfoote gravatar image

I have been trying to install sphero_ros following the instructions given here (I'm sorry I can't publish links. They are present at github mmwise sphere) I get the following error when I do catkin_make install

error: option --install-layout not recognized
CMake Error at sphero_ros/sphero_driver/catkin_generated/safe_execute_install.cmake:4 (message):

Please help me overcome this:

P.S.:The complete trace is:

shahensha@shahensha:~/Development/RobotSim/Python/Sphero$ catkin_make install
Base path: /home/shahensha/Development/RobotSim/Python/Sphero
Source space: /home/shahensha/Development/RobotSim/Python/Sphero/src
Build space: /home/shahensha/Development/RobotSim/Python/Sphero/build
Devel space: /home/shahensha/Development/RobotSim/Python/Sphero/devel
Install space: /home/shahensha/Development/RobotSim/Python/Sphero/install
####
#### Running command: "make cmake_check_build_system" in "/home/shahensha/Development/RobotSim/Python/Sphero/build"
####
####
#### Running command: "make install -j8 -l8" in "/home/shahensha/Development/RobotSim/Python/Sphero/build"
####
[  0%] [  0%] [  0%] Built target std_msgs_generate_messages_cpp
Built target std_msgs_generate_messages_py
Built target std_msgs_generate_messages_lisp
[100%] [100%] [100%] Built target sphero_node_generate_messages_cpp
Built target sphero_node_generate_messages_py
Built target sphero_node_generate_messages_lisp
[100%] Built target sphero_node_generate_messages
Install the project...
-- Install configuration: ""
-- Up-to-date: /home/shahensha/Development/RobotSim/Python/Sphero/install/.catkin
-- Up-to-date: /home/shahensha/Development/RobotSim/Python/Sphero/install/_setup_util.py
-- Up-to-date: /home/shahensha/Development/RobotSim/Python/Sphero/install/env.sh
-- Up-to-date: /home/shahensha/Development/RobotSim/Python/Sphero/install/setup.bash
-- Up-to-date: /home/shahensha/Development/RobotSim/Python/Sphero/install/setup.sh
-- Up-to-date: /home/shahensha/Development/RobotSim/Python/Sphero/install/setup.zsh
-- Up-to-date: /home/shahensha/Development/RobotSim/Python/Sphero/install/.rosinstall
-- Up-to-date: /home/shahensha/Development/RobotSim/Python/Sphero/install/etc/catkin/profile.d/05.catkin_make.bash
-- Up-to-date: /home/shahensha/Development/RobotSim/Python/Sphero/install/etc/catkin/profile.d/05.catkin_make_isolated.bash
-- Up-to-date: /home/shahensha/Development/RobotSim/Python/Sphero/install/lib/pkgconfig/sphero_bringup.pc
-- Up-to-date: /home/shahensha/Development/RobotSim/Python/Sphero/install/share/sphero_bringup/cmake/sphero_bringupConfig.cmake
-- Up-to-date: /home/shahensha/Development/RobotSim/Python/Sphero/install/share/sphero_bringup/cmake/sphero_bringupConfig-version.cmake
-- Up-to-date: /home/shahensha/Development/RobotSim/Python/Sphero/install/share/sphero_bringup/package.xml
-- Installing: /home/shahensha/Development/RobotSim/Python/Sphero/install/share/sphero_bringup/launch
-- Up-to-date: /home/shahensha/Development/RobotSim/Python/Sphero/install/share/sphero_bringup/launch/sphero.launch
-- Up-to-date: /home/shahensha/Development/RobotSim/Python/Sphero/install/lib/pkgconfig/sphero_description.pc
-- Up-to-date: /home/shahensha/Development/RobotSim/Python/Sphero/install/share/sphero_description/cmake/sphero_descriptionConfig.cmake
-- Up-to-date: /home/shahensha/Development/RobotSim/Python/Sphero/install/share/sphero_description/cmake/sphero_descriptionConfig-version.cmake
-- Up-to-date: /home/shahensha/Development/RobotSim/Python/Sphero/install/share/sphero_description/package.xml
-- Installing: /home/shahensha/Development/RobotSim/Python/Sphero/install/share/sphero_description/meshes
-- Up-to-date: /home/shahensha/Development/RobotSim/Python/Sphero/install/share/sphero_description/meshes/SpheroModel.dae
-- Up-to-date: /home/shahensha/Development/RobotSim/Python/Sphero/install/share/sphero_description/meshes/Sphero_Textured.dae
-- Up-to-date: /home/shahensha/Development/RobotSim/Python/Sphero/install/share/sphero_description/meshes/Sphero.dae
-- Up-to-date: /home/shahensha/Development/RobotSim/Python/Sphero/install/share/sphero_description/meshes/SpheroTexture.jpg
-- Installing: /home/shahensha/Development/RobotSim/Python/Sphero/install/share/sphero_description/urdf
-- Up-to-date: /home/shahensha/Development/RobotSim/Python/Sphero/install/share/sphero_description/urdf/sphero.urdf
-- Up-to-date: /home/shahensha/Development/RobotSim/Python/Sphero/install/lib/pkgconfig/sphero_driver.pc
-- Up-to-date: /home/shahensha/Development/RobotSim ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-09-24 14:17:59 -0500

William gravatar image

Looks like your setup.py is not taking the --install-layout option. This might be related to your Setuptools or Distribute Python modules. Can you check what versions of those you have? What OS are you using?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-09-24 08:00:47 -0500

Seen: 150 times

Last updated: Sep 24 '13