ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

robot state publisher error

asked 2013-09-20 12:59:40 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I am learning ROS tutorial (Building a Visual Robot Model with URDF from Scratch) and when I rum this command

roslaunch urdf_tutorial display.launch model:=01-myfirst.urdf

I got following result.

edit retag flag offensive close merge delete


ERROR: cannot launch node of type [robot_state_publisher/state_publisher]: robot_state_publisher ROS path [0]=/opt/ros/hydro/share/ros ROS path [1]=/home/wafeeq/catkin_ws/src/pr2_common ROS path [2]=/opt/ros/hydro/share ROS path [3]=/opt/ros/hydro/share ROS path [4]=/opt/ros/hydro/stacks

wafeeq gravatar image wafeeq  ( 2013-09-20 13:00:26 -0600 )edit

I have also installed robot_state_publisher but it could not find state_publisher a node of it. ERROR: cannot launch node of type [robot_state_publisher/state_publisher]: can't locate node [state_publisher] in package [robot_state_publisher]

wafeeq gravatar image wafeeq  ( 2013-09-20 13:35:05 -0600 )edit

Can anybody help me please?

wafeeq gravatar image wafeeq  ( 2013-09-21 06:58:08 -0600 )edit

I'm trying to incorporate gazebo_ros_control plugin in my own urdf and starting by just putting a controller on a single joint. I keep getting the same error saying "cannont launch node of this type..." ros-hydro-robot-state-publisher installed. Did you find a solution to this?

cstew gravatar image cstew  ( 2014-04-28 11:27:23 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2013-09-21 13:44:25 -0600

mortonjt gravatar image

Do you have ros-hydro-robot-state-publisher installed?

If not, try

sudo apt-get install ros-hydro-robot-state-publisher
edit flag offensive delete link more


wow great it worked. But I had also installed robot_state_publisher manually but it did not work. thanks

wafeeq gravatar image wafeeq  ( 2013-09-22 00:16:23 -0600 )edit

When I tried to run the commanded, it gave me the following error. E: Unable to locate package ros-hydro-robot-state-publisher Is there a way to fix this issue?

sujeet gravatar image sujeet  ( 2018-07-23 18:03:31 -0600 )edit

You probably have to adapt to your version of ROS. For me, it is ros-melodic-robot-state-publisher. You should be able to find the right package name via apt-cache search robot-state-publisher.

wmbolle gravatar image wmbolle  ( 2020-04-12 16:22:27 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2013-09-20 12:59:40 -0600

Seen: 9,226 times

Last updated: Sep 21 '13