Ask Your Question
0

Rosserial Arduino with Groovy

asked 2013-09-15 13:59:26 -0500

Neo gravatar image

updated 2013-11-14 11:11:40 -0500

tfoote gravatar image

Hello. I am new to ROS Running Groovy on 12.04 LTS.

i am trying to add the Rosserial for the Communication of Arduino with ROS. every thing goes fine i follow this tutorial wiki.ros.org/rosserial_arduino/Tutorials/Arduino%20IDE%20Setup.

1.i installed Arduino IDE

2.i run all these commands successfully

cd catkin_workspace/src

git clone //github.com/ros-drivers/rosserial.git

cd catkin_workspace

catkin_make

catkin_make install

source catkin_workspace/install/setup.bash

Al last when i run this Command after going into the libraries folder of sketchbook.

rosrun rosserial_arduino make_libraries.py

i get this Message]

[rospack] Error: stack/package rosserial_arduino not found

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2013-09-15 17:49:23 -0500

updated 2013-09-16 06:10:23 -0500

You forgot the the dot on the last command rosrun rosserial_arduino make_libraries.py . Try that. Also, your source should be source PATH_TO/catkin_workspace/install/setup.bash if in your home directory, source ~/catkin_workspace/install/setup.bash. Can you roscd into rosserial_arduino?

edit flag offensive delete link more

Comments

thnaks i am now able to compile code with ros.h in arduino IDE

Neo gravatar image Neo  ( 2013-09-24 09:49:38 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-09-15 13:59:26 -0500

Seen: 667 times

Last updated: Sep 16 '13