Ask Your Question
4

Anyone has used LabView-ROS Toolkit?

asked 2013-08-21 02:21:12 -0600

pavanpatel gravatar image

updated 2015-10-12 23:47:34 -0600

130s gravatar image

i am trying to connect labview with ros using labview-ros toolkit from clear path robotics.i am trying ro run inbuilt example of joystick demo.vi...but i got error-56 in labview....i think it is not able to publish data to given ros-ip......anyone know how to solve this problem.

thanking you

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-08-22 22:13:03 -0600

clonzz gravatar image

I am also testing the toolkit in few hours ago. At the moment, I have successfully connected the toolkit to the Rosbridge in ROS by looking at no error status in Labview but have not transfer any data yet. Have you installed the Rosbridge package in ROS? What IP did you put in the string? What is the explanation of error 56?

edit flag offensive delete link more

Comments

1

yes i have installed rosbridge package.......i have given the ip on which ros is running.......plz tell me how can i solve it.....right now i am getting error 62....... error 62 is that the VI that opened the connection has finished executing and has closed, when a VI finishes executing in LabVIEW the resources are automatically closed to ensure any open resources arn't left dangling.

pavanpatel gravatar imagepavanpatel ( 2013-09-03 22:44:47 -0600 )edit

I get the same error 62. it's been a week for me to try to solve this issue, but still no idea yet.

DavidSuh gravatar imageDavidSuh ( 2013-09-18 03:34:49 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2013-08-21 02:21:12 -0600

Seen: 723 times

Last updated: Aug 22 '13